در توسینسو تدریس کنید

و

با دانش خود درآمد کسب کنید

NAT چیست ؟ و چگونه از آن در تجهیزات سیسکو استفاده کنیم !

IPv4 نسخه چهارم پروتکل اینترنت نسبت به تقاضای فعلی شبکه به لحاظ تعداد IP محدود می باشد. به همین دلیل امکان درنظر گرفتن IP برای تمام تجهیزاتی که به اینترنت می خواهند متصل شود وجود ندارد. علاوه بر این محدودیت ، استفاده از IP های معتبر موجود در اینترنت نیاز به پرداخت هزینه است.

NAT) Netwrok Address Translate) برای برطرف شدن این مشکلات ارائه شد. در شبکه های محلی از Private IP استفاده می شود و برای شبکه تعداد محدودی IP معتبر (Public)گرفته می شود و با استفاده از سرویس NAT ارتباط دستگاه ها به اینترنت برقرار می شود.

NAT چیست ؟ و چگونه از آن در تجهیزات سیسکو استفاده کنیم !

NAT یک IP به IP دیگر را تبدیل می کند یا عبارتی Private IP را به Public IP تبدیل می کند. به طور مثال یک شبکه را در نظر بگیرد که دارای 20 دستگاه است که می خواهند از اینترنت استفاده کنند با استفاده از سرویس NAT به جای اینکه برای هر دستگاه یک Public IP تهیه شود کلا یک Public IP تهیه می شود و برای دستگاه ها Private IP در نظر گرفته می شود و این دستگاه ها با استفاده از یک Public IP به اینترنت متصل می شوند. با اینکار در مصرف IP و هزینه صرفه جویی می شود.

رنج های Private IP :


  • 10.0.0.0 تا 10.255.255.255
  • 172.16.0.0 تا 172.31.255.255
  • 192.168.0.0 تا 192.168.255.255

برخی از موارد مورد استفاده NAT :


  • صرفه جویی در مصرف IP و هزینه
  • زمانی که بخواهیم IP را به دلایلی عوض کنیم
  • زمانی که شبکه داخلی از Private IP استفاده می کند.
  • برقراری ارتباط بین دو شبکه که دارای رنج IP یکسانی هستند.
  • نخواهیم رنج IP که در شبکه مورد استفاده قرار می گیرد از بیرون دیده شود.
  • زمانی که مقصد ، رنج IP داخلی شبکه ما را نمی شناسد.

سرویس ها و ویژگی هایی که با NAT مشکل دارند:


  • ناسازگاری با برخی از پروتکل ها : برخی از پروتکل ها IP آدرس مورد استفاده را در لایه هفتم نیز استفاده می کنند که باعث ایجاد مشکل می شود.
  • برخی از پروتکل های رمزنگاری و احرازهویت : یکی از مسائل در رمز نگاری و احراز هویت جلوگیری از تغییر بسته ها در حین ارسال می باشد.
  • Log گیری و گزارش گیری : با توجه به تغییر IP بررسی عملکرد و گزارشگیری مشکل است.

مفاهیم NAT :


Inside Local Address : آدرس هایی که برای شبکه داخلی مورد استفاده قرار می گیرد.(Private IP)

Inside Global Address : آدرس هایی که دستگاه های داخلی شبکه با آن از بیرون دیده می شوند. (Public IP)

Outside Local Address : آدرسی هایی که دستگاه های داخل شبکه ، دستگاه های خارج از شبکه را با آن می بینیم و می تواند آدرس Private باشد. نکته ای که وجود دارد این آدرس از طریق شبکه داخلی قابل مسیریابی است.

Outside Global Address : آدرس های Public مربوط به دستگاه های بیرون از شبکه ، که ما با آنها ارتباط برقرار می کنیم مانند Public IP سرور سایت Iitpro

کاربردهای اصلی NAT :


  • Source NAT : امکان ایجاد ارتباط یک دستگاه که دارای Private IP است را به اینترنت فراهم می کند.
  • Destination NAT : امکان ایجاد ارتباط به یک دستگاه که دارای Private IP است را از اینترنت فراهم می کند.

انواع NAT :


  • Static NAT
  • Dynamic NAT
  • (Overloaded (PAT

Static NAT :


در این روش یک آدرس Private را تبدیل به یک آدرس Public می کند یا به عبارتی یک دستگاه از شبکه داخلی به یک IP از شبکه خارجی تبدیل می شود.

NAT چیست ؟ و چگونه از آن در تجهیزات سیسکو استفاده کنیم !

با توجه به تصویر فوق Static NAT را پیاده سازی می کنیم:

با استفاده از دستور زیر مشخص می کنیم که IP 192.168.1.5 به 5.5.5.1 تبدیل شود.

Router(config)#ip nat inside source static 192.168.1.5 5.5.5.1

سپس شبکه را به دو بخش inside و outside تقسیم می کنیم و دستورات زیر را روی اینترفیس مربوطه وارد می کنیم:

Router(config)#interface fastethernet 0/0
Router(config-if)#ip nat inside
Router(config)#interface fastethernet 0/1
Router(config-if)#ip nat outside

برای مشاهده وضعیت NAT از دستور زیر استفاده کنید:

Router#show ip nat translations

NAT چیست ؟ و چگونه از آن در تجهیزات سیسکو استفاده کنیم !

Dynamic NAT :


در این روش یک pool (رنج) از آدرس های Public را به یک رنج از Private IP شبکه داخلی اختصاص می دهیم. در این حالت تعداد IPهای داخلی و خارجی باید برابر باشد.

NAT چیست ؟ و چگونه از آن در تجهیزات سیسکو استفاده کنیم !

در ابتدا با یک ACL مشخص می کنیم که چه بسته هایی اجازه NAT شدن را دارند.

Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255
  • نکته : NAT کردن براساس پارامترهای دیگر مانند پروتکل ، اینترفیس ، مقصد و ... امکان پذیر است برای این حالت ، به جای Standard ACL از Extended ACL استفاده می کنیم.

یک pool تعریف می کنیم و Public IP ها را در آن مشخص می کنیم.

Router(config)#ip nat pool itpro 5.5.5.1 5.5.5.3 prefix-length 24

ACL تعریف شده را به NAT اختصاص می دهیم

Router(config)#ip nat inside source list 1 pool itpro

سپس شبکه را به دو بخش inside و outside تقسیم می کنیم و دستورات زیر را روی اینترفیس مربوطه وارد می کنیم:

Router(config)#interface fastethernet 0/0
Router(config-if)#ip nat inside
Router(config)#interface fastethernet 0/1
Router(config-if)#ip nat outside

برای مشاهده وضعیت NAT از دستور زیر استفاده کنید:

Router#show ip nat translations

NAT چیست ؟ و چگونه از آن در تجهیزات سیسکو استفاده کنیم !

(Overloaded (PAT :


این روش مشابه Dynamic NAT می باشد با این تفاوت که به تعداد دستگاه هایی که می خواهند از اینترنت استفاده کنند نیاز به IP نداریم و تعداد می تواند کمتر و یا حتی یک عدد باشد.

NAT چیست ؟ و چگونه از آن در تجهیزات سیسکو استفاده کنیم !

دستورات اجرای این روش مشابه Dynamic می باشد فقط یک تفاوت کوچک دارد:

Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255
Router(config)#ip nat pool itpro 5.5.5.1 5.5.5.3 prefix-length 24

در اینجا کلمه overload را به انتهای دستور اضافه می کنیم:

Router(config)#ip nat inside source list 1 pool itpro overload
Router(config)#interface fastethernet 0/0
Router(config-if)#ip nat inside
Router(config)#interface fastethernet 0/1
Router(config-if)#ip nat outside

برای مشاهده وضعیت NAT از دستور زیر استفاده کنید:

Router#show ip nat translations

NAT چیست ؟ و چگونه از آن در تجهیزات سیسکو استفاده کنیم !

Overlapping NAT :


بعضی از مواقع می خواهیم ارتباط بین دو شبکه که دارای رنج IP یکسانی هستند را برقرار کنیم برای اینکار از Overlapping NAT به صورت زیر استفاده می کنیم:

NAT چیست ؟ و چگونه از آن در تجهیزات سیسکو استفاده کنیم !

همانطور که در تصویر می بینید سرور1 و سرور2 هر دو دارای آدرس 192.168.1.11/24 هستند و هر کدام در یک شبکه قرار دارند. در این سناریو می خواهیم ارتباط این دو سرور را با استفاده از NAT برقرار کنیم:

برای پیاده سازی این سناریو از دستورات زیر استفاده می کنیم که مشابه Static NAT می باشد.

در ابتدا روی روتر R1 :

Router(config)# ip nat inside source static 192.168.1.11 192.168.12.11
Router(config)#interface fastethernet 0/0
Router(config-if)#ip nat inside
Router(config)#interface fastethernet 0/1
Router(config-if)#ip nat outside

سپس روی روتر R2 :

Router(config)# ip nat inside source static 192.168.1.11 192.168.12.12
Router(config)#interface fastethernet 0/0
Router(config-if)#ip nat inside
Router(config)#interface fastethernet 0/1
Router(config-if)#ip nat outside

به این صورت سرور1 از طریق آدرس 192.168.12.12 با سرور2 می تواند ارتباط برقرار کند و سرور2 از طریق آدرس 192.168.12.11 با سرور1 می تواند ارتباط برقرار کند.

نویسنده : جعفر قنبری شوهانی

منبع : جزیره سیسکو وب سایت توسینسو

هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی می باشد.

#nat_چیست #destination_nat_چیست #source_nat_چیست #network_address_translation_چیست
عنوان
1 NAT چیست ؟ و چگونه از آن در تجهیزات سیسکو استفاده کنیم ! رایگان
2 پنهان کردن و تغییر حقیقت در رابطه با آدرس مبدا بسته ها توسط NAT رایگان
3 روش های مختلف پیاده سازی NAT رایگان
4 (Port Address Translation (PAT پرکاربردترین روش NAT رایگان
زمان و قیمت کل 0″ 0
15 نظر
aziz64

عالی بود و استفاده کردم

sara sadeghi

تشکر.

عااااالی بود.

مهسا مصلح

ممنون مرسی ولی در قسمت چهارم "برخی از موارد استفاده از NAT" نوشتین : " برقراری ارتباط بین دو شبکه که دارای رنج IP یکسانی هستند."

چرا رنج یکسان؟

سوال دومم اینه که جایی اشاره کردین " NAT با برخی از پروتکلهای مورد استفاده در لایه هفت سازگار نیست"، اگر امکانش هست یکم بیشتر توضیح بدین با چه پروتکلهایی و چرا؟

جعفر قنبری شوهانی

بعضی مواقع شبکه های وجود داره که رنج IP یکسانی دارند و می خواین بین این دو شبکه ارتباط برقرار کنید و امکان تغییر رنج IP این شبکه ها به دلایل مختلف وجود نداره در نتیجه از روش Overlapping که یک مثال اون رو توی مقاله گذاشتم باید استفاده بشه اما در کل روش جالبی نیست و تا جایی که امکان داره نباید ازش استفاده کنید برای موارد خاص کاربرد داره

برخی از پروتکل های لایه هفتم میان اطلاعات مربوط به IP رو در لایه هفتم استفاده می کنند بعد زمانی که NAT انجام میشه فقط IP آدرس لایه سوم ترجمه میشه و IP که در لایه هفتم استفاده شده تغییری نمی کنه در نتیجه باعث بروز مشکل میشه با آشنایی بیشتر از لینک زیر استفاده کنید :

Application Layer Protocols with Embedded Network Information

مهسا مصلح

مرسی ممنون از توضیحاتتون

mr_E

ببخشید . یه سوال:

در مبحث overlapping الان سرور 1 میتونه ip سرور 2 رو پینگ کنه ؟

من سناریو رو انجام دادم نتونست

جعفر قنبری شوهانی

بله براساس مثال بالا از طریق IP آدرس های 192.168.12.12 و 192.168.12.11 می تونند همدیگر رو ببینند

mr_E

من دقیقا مثل شما کانفیگ کردم.(کانفیگ هاتون رو کپی کردم)

ولی وقتی ping کردم از طریق simulation mode بسته رو پیگیری که کردم دیدم داره به خودش میده.

جعفر قنبری شوهانی

باید چک کنم و نتیجه رو اعلام می کنم

جعفر قنبری شوهانی

خوشبختانه همون سناریویی که برای این مقاله آماده کرده بودم رو روی سیستم داشتم و تست کردم و مشکلی نداشت و درست کار می کرد کانفیگ ها رو براتون میزارم تا بررسی کنید :

روتر R1 :

R1#show running-config 
Building configuration...

Current configuration : 1221 bytes
!
! Last configuration change at 15:46:40 UTC Fri Sep 30 2016
upgrade fpd auto
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
!
!
!         
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!
!         
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.12.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat pool itpro 192.168.12.11 192.168.12.20 prefix-length 24
ip nat inside source static 192.168.1.11 192.168.12.11
!
!
!
!
control-plane
!
!
!
mgcp profile default
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
 transport input all
!
!
end

روتر R2 :

R2#show running-config 
Building configuration...

Current configuration : 1158 bytes
!
! Last configuration change at 15:47:02 UTC Fri Sep 30 2016
upgrade fpd auto
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
!
!
!         
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!
!         
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.2 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.12.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source static 192.168.1.11 192.168.12.12
!
!
!
!
control-plane
!
!
!
mgcp profile default
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
 transport input all
!
!
end

سرور 1 :

Server1#show running-config 
Building configuration...

Current configuration : 696 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Server1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!         
!
!
!
!
ip tcp synwait-time 5
!
!
interface Ethernet0/0
 ip address 192.168.1.11 255.255.255.0
 half-duplex
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

سرور 2 :

Server2#show running-config 
Building configuration...

Current configuration : 696 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Server2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!         
!
!
!
!
ip tcp synwait-time 5
!
!
interface Ethernet0/0
 ip address 192.168.1.11 255.255.255.0
 half-duplex
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
mr_E

ممنون. حتما تست می کنم.

ahaqiqat

سلام

ممنون از مقاله خوبتون.

من هم طبق صحبت دوستمون از رئوی کانفیکهای شما انجام دادم ولی سرور ها هم رو پینگ ندارن در overlapping.

مشکل چیه؟

حامد

با سلام و وقت بخير

واقعا ممنون بسيار خوب و عالي و قابل فهم توضيح داديد استاد.

سپاس

m_valiolahi

سلام این یعنی چی؟

Destination NAT : امکان ایجاد ارتباط به یک دستگاه که دارای Private IP است را از اینترنت فراهم می کند.

جعفر قنبری شوهانی

یعنی می تونید یک سرور یا یک کلاینت که در شبکه داخلی قرار داره رو با این قابلیت از طریق اینترنت ببینید. به طور معمولا به خاطر اینکه ما در شبکه داخلی از IP Private استفاده می کنیم و به تجهیزاتمون از طریق اینترنت نمی تونیم دسترسی پیدا کنیم اما با این قابلیت این امکان فراهم میشه

نظر شما
برای ارسال نظر باید وارد شوید.
از سرتاسر توسینسو
تنظیمات حریم خصوصی
تائید صرفنظر
×

تو می تونی بهترین نتیجه رو تضمینی با بهترین های ایران بدست بیاری ، پس مقایسه کن و بعد خرید کن : فقط توی جشنواره تابستانه می تونی امروز ارزونتر از فردا خرید کنی ....