در توسینسو تدریس کنید

و

با دانش خود درآمد کسب کنید

پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت سوم

در ادامه مقالات قبلی می خواهیم با سایر مفاهیم این پروتکل آشنا شویم

OSPF Neighbor States :

وضعیت های که روترها سپری می کنند تا همسایه شوند به صورت زیر است:

  • Down
  • Initialize
  • Two way
  • Exstart
  • Exchange
  • Loading
  • Full

شبکه های Point to Point :

در این حالت بین دو روتر یک لینک اختصاصی وجود دارد مانند اینترفیس سریال

پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت سوم

در این شبکه ها مراحل همسایگی و تبادل اطلاعات توپولوژی به صورت زیر است:

  • Down : هنوز OSPF روی روتر اجرا نشده و هیچ بسته ای در رابطه با OSPF ردوبدل نمی شود.
  • Initialize : در این وضعیت OSPF اجرا شده و روتر شروع به ارسال Hello به آدرس 224.0.0.5 که multicast است می کند.
  • Two way : در این وضعیت روتر یک Hello که حاوی RID خودش است دریافت می کند. در صورت تطبیق شرایط مورد نیاز همسایگی با روتر مقابل همسایه شده و به آن با قرار دادن RID روتر مقابل پاسخ می دهد در این مرحله ارتباط به صورت unicast انجام می شود.
  • Exstart : در این مرحله کسی که قرار است تبادل اطلاعات توپولوژی را شروع کند مشخص می شود که در اینجا کسی که RID بزرگتری دارد اینکار را شروع می کند.
  • Exchange : در این مرحله روتر انتخاب شده در مرحله قبل اقدام به ارسال یک بسته DBD می کند که شامل خلاصه ای از شبکه های متصل به آن روتر می باشد سپس روتر مقابل نیز اینکار را انجام می دهد و هر روتر بعد از دریافت بسته DBD یک بسته ACK به منظور تایید دریافت بسته ارسال می کند. اینکار توسط روتر مقابل نیز انجام می شود.
  • Loading : روتر که بسته DBD را دریافت کرد آنرا با شبکه هایی که دارد مقایسه می کند و برای شبکه هایی که آنها را ندارد توسط بسته LSR درخواست ارسال می کند که اطلاعات کامل آنها را می خواهد. روتر مقابل اطلاعات کامل را توسط یک بسته LSU ارسال می کند و بعد از دریافت LSU یک بسته ACK به منظور تایید دریافت ارسال می کند. این عمل توسط روتر مقابل نیز انجام می شود.
  • Full : حالا اطلاعات جدول توپولوژی کامل شده و هر روتر به صورت جداگانه الگوریتم SPF را اجرا می کنند و جدول مسیریابی خود را بروز می کنند.

شبکه های (Multi Access (Broadcast :

Multi Access لینک هایی هستند که به صورت اشتراکی مورد استفاده قرار می گیرند. مانند Ethernet

پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت سوم

در این نوع شبکه ها ارتباط و تبادل اطلاعات دو به دو انجام نمی شود و یک روتر به عنوان Designated Router یا DR انتخاب می شود و وظیفه بروز نگه داشتن همه روترها را دارد در این حالت DR یک نقطه حساس در شبکه است و اگر این روتر از کار بیافتد شبکه نیز مختل می شود برای جلوگیری از این مشکل یک روتر به عنوان Backup Designated Router یا BDR در نظر گرفته می شود و به طور دائم ، فعال و زنده بودن DR را چک می کند و در صورت بروز مشکل اطلاعات لازم برای DR شدن را دارد.

در شبکه های Multi Access همه روترها فقط با روتر DR و BDR مراحل برقراری و تبادل اطلاعات را که در شبکه های Point To Point گفته شد انجام می دهند و در این شبکه ها روترهای DROther بسته های خود را به آدرس 224.0.0.5 ارسال می کنند و 224.0.0.6 توسط DR برای ارسال بسته ها مورد استفاده قرار می گیرد.

  • نکته : بهتر است در انتخاب DR و BDR ما نقش داشته باشیم و بهترین روترها را برای اینکار انتخاب کنیم مثلا روترهایی که توانا بالاتری دارند یا به همه روترها لینک مستقیم دارند.
  • نکته : سایر روترها به عنوان DRother در نظر گرفته می شوند.

شبکه های NBMA :

این شبکه ها از یک مدیا مشترک استفاده می کنند ولی ترافیک به صورت مستقیم بین دستگاه ارسال می شود و ترافیک Broadcast در این شبکه نداریم در این شبکه ها امکان استفاده از OSPF وجود دارد و از مکانیزم DR و BDR بهره می گیرد ولی همسایگی باید به صورت دستی تعریف شود.

پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت سوم

شبکه های (Point to Multipoint (PTMP :

مکانیزم این شبکه ها برای OSPF همانند شبکه های Point to Point است.

پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت سوم

شبکه های (Point to Multipoint nonbroadcast (PTMNB :

مکانیزم این شبکه ها برای OSPF همانند شبکه های Point to Point است با این تفاوت که باید همسایگی به صورت دستی انجام گیرد.

نکاتی در پیاده سازی OSPF :

پیاده سازی OSPF نسبت به سایر پروتکل های مسیریابی مانند EIGRP نیازمند یک طرح و برنامه دقیق تر است چون طراحی OSPF شرایط و نیازهای خاص خودش را می طلبد. برای پیاده سازی OSPF شرایط زیر را در نظر بگیرد:

  • وضعیت فعلی شبکه : یک لیست از IP address های مورد استفاده ، انواع لینک ها و ارتباطات ، پهنای باندها ، تجهیزات موجود و ... تهیه کنید.
  • اطلاعات مورد نیاز : در اینجا باید مشخص کنیم که از چه شماره Process برای OSPF استفاده شود ، RID بر چه اساس انتخاب شود ، چه روترهایی OSPF را اجرا کنند و ...
  • IP Plan : همه جوانب را برای پیاده سازی یک طرح ایده ال برای سیستم آدرس دهی در نظر بگیرد.
  • طراحی سلسله مراتبی : OSPF نیاز به پیاده سازی سلسله مراتبی دارد. باید یک Area Backbone یا همان Area 0 در نظر گرفت و سایر Area ها باید به گونه ای طراحی شوند که به Area 0 به صورت مستقیم متصل باشند.
  • انتخاب تجهیزات : روترهایی را به عنوان ABR ، ِDR و ... انتخاب کنید که به لحاظ توانایی و شرایط بتوانند وظایف خود انجام دهند.
  • آینده نگری : گسترش و تغییرات شبکه در آینده را در نظر بگیرد.
  • تهیه گزارش و برنامه پایان کار : در انتها شرایط ، مراحل و ... پیاده سازی OSPF را به صورت Document تهیه کنید تا در صورت نیاز بتوانید از آنها به عنوان مرجع استفاده کنید.

OSPF Summarization :

در OSPF علاوه بر اینکه خلاصه سازی مسیر ها باعث کاهش تعداد رکورد های جدول مسیریابی می شود یک ویژگی بسیار مهم دیگر دارد که به آن می پردازیم.

زمانیکه در Routeها تغییری به وجود می آید باعث می شود که الگوریتم SPF دوباره اجرا شده و باعث درگیر شدن CPU و Ram روترها گردد. حال یک شبکه بزرگ را در نظر بگیرد که دارای شبکه های فراوان و تغییرات بسیار است و این باعث می شود که روترها همیشه درگیر اجرای الگوریتم SPF باشند برای جلوگیری از این مشکل و هدر رفتن منابع از قابلیت Summarization استفاده می کنیم که باعث می شود تغییرات Routeها کمتر مبادله شوند و در هنگام تغییرات فقط روترهای داخل آن Area درگیر اجرای الگوریتم SPF شوند.

دو نوع Summarzation داریم :

  • Inter-area (LSA Type 3) Route Summarization : این روت توسط روترهای ABR ایجاد می شود و با دستور زیر استفاده می شود:
  • Router(config)#router ospf 1
    Router(config-router)#area 1 range 172.16.0.0 255.240.0.0
    
  • External (LSA Type 5) Route Summarization : این روت توسط روترهای ASBR ایجاد می شود و با دستور زیر استفاده می شود:
  • Router(config)#router ospf 1
    Router(config-router)#summary-address 192.168.0.0 255.255.0.0
    

OSPF Authentication :

در پروتکل OSPF امکان استفاده از ماکنیزم احراز هویت(Authentication) وجود دارد با استفاده از این قابلیت شبکه را در برابر اتصال روترهای غیرمجاز به شبکه OSPF و هرگونه تغییرات محفوظ نگه می دارد. در نتیجه هر روتر در هنگام دریافت بسته های OSPF ابتدا هویت آنها را تایید می کند.

به دو صورت زیر امکان استفاده از Authentication دارد :

  • Clear Text : در این حالت احراز هویت بودن رمز نگاری انجام می گیرد درنتیجه در صورتی که بسته ها اگر Sniff شوند امکان دستیابی به پسورد وجود دارد.
  • MD5 : در این حالت برای افزایش امنیت از مکانیزم رمزنگاری نیز استفاده می شود.

مکانیزم احرازهویت را به دو صورت زیر می توان پیاده سازی کرد:

  • در اینترفیس مورد نظر با استفاده از دستور زیر:
  • Router(config)#interface fastethernet 0/1
    Router(config-if)#ip ospf authentication-key 123
    Router(config-if)#ip ospf authentication message-digest
    
  • در حالت دوم احراز هویت را برای یک Area فعال می کنیم:
  • Router(config)#router ospf 1
    Router(config-if)#ip ospf authentication message-digest
    

سپس روی اینترفیس های مورد نظر کلید را مشخص می کنیم.

Passive Interface :

فعال کردن این ویژگی روی یک اینترفیس باعث می شود که دیگر روی آن اینترفیس بسته Hello ارسال نشود و دیگر از طریق این اینترفیس نمی تواند با روتری دیگر همسایه شود. روی پورت هایی که انتظار نداریم روی آنها همسایگی داشته باشیم مانند اینترفیس متصل به LAN بهتر است این ویژگی فعال شود.

برای اینکار از دستور زیر استفاده می شود:

Router(config)#interface fastethernet 0/0
Router(config-if)#passive-interface

تنظیمات ساده OSPF :

برای اجرای OSPF کافیست که در Config mode دستور زیر را وارد کنید:

Router(config)#router ospf 5
  • نکته : در اینجا عدد 5 شماره process می باشد که می توان روی یک روتر چند OSPF اجرا کرد.
  • نکته : این شماره می تواند روی روتر های مختلف متفاوت باشد.

سپس با دستور زیر اینترفیس هایی که می خواهیم به بقیه اعلام می کنیم. در انتهای دستور با عبارت area مشخص می کنیم این اینترفیس در کدام area قرار دارد:

Router(config-Router)#network 192.168.1.0 0.0.0.255 area 0
  • نکته : با دستور زیر نیز می توانیم عمل فوق را از طریق اینترفیس انجام دهیم:
  • Router(config)#interface fastethernet 0/0
    Router(config-if)#ip ospf 5 area 0
    

در صورتی که بخواهیم یک اینترفیس Loop Back بسازیم از دستورات زیر استفاده می کنیم:

Router(config)# interface loopback 0
Router(config-if)# ip address 10.0.0.1 255.255.255.255

  • نکته : استفاده از Loopback به این لحاظ که یک اینترفیس مجازی است و مانند اینترفیس های فیزیکی امکان قطع شدن ندارد برای RID مناسب است و علاوه بر آن امکان ping و trace را به ما می دهد که برای troubleshooting مفید است.

در صورتی که بخواهیم RID را به صورت دستوری مشخص کنیم به صورت زیر عمل می کنیم :

Router(config)# router ospf 5
Router(config-router)# router-id 10.0.0.1

در صورتی که بخواهیم پروسه OSPF را ریست کنیم از دستور زیر استفاده می کنیم:

Router#clear ip ospf process

جهت دیدن نوع شبکه می توانیم از دستور زیر استفاده کنیم:

Router#show ip ospf interface

اگر بخواهیم نوع شبکه را مشخص کنیم از دستور زیر استفاده می کنیم:

Router(config)#interface fastethernet 0/0
Router(config-if)#ip ospf network point-to-multipoint

شبکه هایی که از Broadcast پشتیبانی نمیکنند مانند NBMA باید همسایگی در آنها به صورت دستی انجام پذیرد که به صورت زیر است:

Router(config)#router ospf 5
Router(config-router)#neighbor 192.168.1.2

برای بررسی و دیدن تنظیمات و خطایابی از دستورات زیر استفاده می کنیم:

Router#show ip ospf adjacencies
Router#show ip ospf neighbor
Router#show ip route
Router#show ip route ospf
Router#show ip protocol
Router#show ip ospf
Router#show ip ospf interface
Router#debug ip ospf packet

در قسمت بعدی این سری آموزشی یک سناریوی عملی را پیاده سازی خواهید کرد تا با مفاهیمی که تا الان گفته شد بهتر آشنا شویم.

موفق ، پیروز و Itpro باشید.

نویسنده : جعفر قنبری شوهانی

منبع : جزیره سیسکو وب سایت توسینسو

هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی می باشد

#خلاصه_سازی_در_ospf #passive_interface_در_ospf #وضعیت_های_همسایگی_ospf #ospf_چیست #عملکرد_ospf_در_شبکه
عنوان
1 پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت اول رایگان
2 پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت دوم رایگان
3 پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت سوم رایگان
4 پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت چهارم رایگان
5 پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت پنجم رایگان
زمان و قیمت کل 0″ 0
1 نظر
mamadco

وضعیت های که روترها سپری می کنند تا همسایه شوند به صورت زیر است:

Down

Initialize

Two way

Exstart

Exchange

Loading

Full

---

سلام مگر تشکیل همسایگی تا فاز 2way نیست ؟ در حقیقت بعد از فاز 2way و برسی پارامترها فاز تشکیل همسایگی تموم میشه و با شروع مرحله exstart وارد مرحله تبادل جداول میشیم .

نظر شما
برای ارسال نظر باید وارد شوید.
از سرتاسر توسینسو
تنظیمات حریم خصوصی
تائید صرفنظر
×

تو می تونی بهترین نتیجه رو تضمینی با بهترین های ایران بدست بیاری ، پس مقایسه کن و بعد خرید کن : فقط توی جشنواره تابستانه می تونی امروز ارزونتر از فردا خرید کنی ....