در توسینسو تدریس کنید

و

با دانش خود درآمد کسب کنید

پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت چهارم

در بخش های قبلی با مفاهیم پروتکل OSPF آشنا شدیم و همینطور که قول داده بودیم در این بخش می خواهیم یک سناریو را پیاده سازی کنیم تا با این مفاهیم که تا این لحظه مطرح شد بیشتر آشنا شویم.

سناریو :

یک شرکت را در نظر بگیرد که دفتر مرکزی آن در تهران قرار دارد و تعدادی نمایندگی در سطح چند استان دارد می خواهیم برای برقراری ارتباط این دفاتر و مسیریابی از پروتکل OSPF استفاده کنیم.

در ابتدا لیستی از شعب و شبکه های آنها را تهیه می کنیم:

  • دفتر مرکزی : در تهران مستقر است و سرورهای شرکت دفتر مرکزی قرار دارند رنج IP شبکه LAN مورد استفاده در دفتر مرکزی 10.1.0.0/24 می باشد.
  • شعبه ولیعصر تهران : رنج شبکه مورد استفاده برای آن 10.1.1.0/24 می باشد.
  • شعبه کرج : رنج شبکه مورد استفاده برای آن 10.1.2.0/24 می باشد.
  • شعبه مشهد : رنج شبکه مورد استفاده برای آن 10.2.1.0/24 می باشد.
  • شعبه سبزوار : رنج شبکه مورد استفاده برای آن 10.2.2.0/24 می باشد.
  • شعبه قوچان : رنج شبکه مورد استفاده برای آن 10.2.3.0/24 می باشد.
  • شعبه اهواز : رنج شبکه مورد استفاده برای آن 10.3.1.0/24 می باشد.
  • شعبه خرمشهر : رنج شبکه مورد استفاده برای آن 10.3.2.0/24 می باشد.
  • شعبه آبادان : رنج شبکه مورد استفاده برای آن 10.3.3.0/24 می باشد.
  • شعبه اصفهان : رنج شبکه مورد استفاده برای آن 10.4.1.0/24 می باشد.
  • شعبه کاشان : رنج شبکه مورد استفاده برای آن 10.4.2.0/24 می باشد.
  • شعبه تبریز : رنج شبکه مورد استفاده برای آن 10.5.1.0/24 می باشد.

با استفاده از خطوط مخابراتی ارتباط بین شعب و دفتر مرکزی به این صورت که شهرستان ها به مرکز استان و از مرکز استان به دفتر مرکزی به صورتی که در نقشه می بینید متصل شده اند :

پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت چهارم

به توجه به موقعیت شعب ، Areaبندی را براساس استان ها انجام می دهیم که به صورت زیر می شود.

پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت چهارم

در ابتدا برای هر روتر IP مورد استفاده در شبکه LAN را تعریف می کنیم (در اینجا از اینترفیس Loopback ) استفاده می کنیم و IP پورت های WAN را مشخص می کنیم و سپس OSPF را روی آن فعال می کنیم به صورت زیر:

روتری دفتر مرکزی:

Markazi(config)#interface Loopback1
Markazi(config-if)#ip address 10.1.0.1 255.255.255.0
Markazi(config)#interface Serial0/0
Markazi(config-if)#ip address 172.16.3.1 255.255.255.0
Markazi(config)#interface Serial0/1
Markazi(config-if)#ip address 192.168.1.1 255.255.255.0
Markazi(config)#interface Serial0/2
Markazi(config-if)#ip address 192.168.2.1 255.255.255.0
Markazi(config)#interface Serial0/3
Markazi(config-if)#ip address 172.16.4.1 255.255.255.0
Markazi(config)#interface Serial0/4
Markazi(config-if)#ip address 172.16.2.1 255.255.255.0
Markazi(config)#interface Serial0/5
Markazi(config-if)#ip address 172.16.5.1 255.255.255.0
Markazi(config)#router ospf 1
Markazi(config-router)#network 10.1.0.0 0.0.0.255 area 0
Markazi(config-router)#network 172.16.2.0 0.0.0.255 area 0
Markazi(config-router)#network 172.16.3.0 0.0.0.255 area 0
Markazi(config-router)#network 172.16.4.0 0.0.0.255 area 0
Markazi(config-router)#network 172.16.5.0 0.0.0.255 area 0
Markazi(config-router)#network 192.168.1.0 0.0.0.255 area 0
Markazi(config-router)#network 192.168.2.0 0.0.0.255 area 0

روتر شعبه ولیعصر :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.1.1.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.1.1.0 0.0.0.255 area 0
Router(config-router)#network 192.168.1.0 0.0.0.255 area 0

روتر شعبه کرج :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.1.2.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.1.2.0 0.0.0.255 area 0
Router(config-router)#network 192.168.2.0 0.0.0.255 area 0

روتر شعبه مشهد :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.2.1.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 172.16.2.2 255.255.255.0
Router(config)#interface Serial0/1
Router(config-if)#ip address 192.168.22.1 255.255.255.0
Router(config)#interface Serial0/2
Router(config-if)#ip address 192.168.23.1 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.2.1.0 0.0.0.255 area 1
Router(config-router)#network 172.16.2.0 0.0.0.255 area 0
Router(config-router)#network 192.168.22.0 0.0.0.255 area 1
Router(config-router)#network 192.168.23.0 0.0.0.255 area 1

روتر شعبه سبزوار :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.2.2.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 192.168.22.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.2.2.0 0.0.0.255 area 1
Router(config-router)#network 192.168.22.0 0.0.0.255 area 1

روتر شعبه قوچان :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.2.3.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 192.168.23.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.2.3.0 0.0.0.255 area 1
Router(config-router)#network 192.168.23.0 0.0.0.255 area 1

روتر شعبه اصفهان :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.4.1.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 172.16.4.2 255.255.255.0
Router(config)#interface Serial0/1
Router(config-if)#ip address 192.168.42.1 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.4.1.0 0.0.0.255 area 2
Router(config-router)#network 172.16.4.0 0.0.0.255 area 0
Router(config-router)#network 192.168.42.0 0.0.0.255 area 2

روتر شعبه کاشان :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.4.2.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 192.168.42.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.4.2.0 0.0.0.255 area 2
Router(config-router)#network 192.168.42.0 0.0.0.255 area 2

روتر شعبه اهواز :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.3.1.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 172.16.3.2 255.255.255.0
Router(config)#interface Serial0/1
Router(config-if)#ip address 192.168.32.1 255.255.255.0
Router(config)#interface Serial0/2
Router(config-if)#ip address 192.168.33.1 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.3.1.0 0.0.0.255 area 3
Router(config-router)#network 172.16.3.0 0.0.0.255 area 0
Router(config-router)#network 192.168.32.0 0.0.0.255 area 3
Router(config-router)#network 192.168.33.0 0.0.0.255 area 3

روتر شعبه خرمشهر :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.3.2.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 192.168.32.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.3.2.0 0.0.0.255 area 3
Router(config-router)#network 192.168.32.0 0.0.0.255 area 3

روتر شعبه آبادان :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.3.3.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 192.168.33.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.3.3.0 0.0.0.255 area 3
Router(config-router)#network 192.168.33.0 0.0.0.255 area 3

روتر شعبه تبریز :

outer(config)#interface Loopback1
Router(config-if)#ip address 10.5.1.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 172.16.5.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.5.1.0 0.0.0.255 area 5
Router(config-router)#network 172.16.5.0 0.0.0.255 area 0

تنظیمات مربوطه تمام شده و روترها همسایه شده و روت ها بین آنها رد و بدل شده در تصویر زیر با استفاده از دستور Show ip route جدول مسیریابی روتر دفتر مرکزی نمایش داده می شود.


در تصویر می بینید مسیرهایی که با حرف اختصار O نمایش داده می شود از طریق OSPF دریافت شده است.

پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت چهارم

همچنین با دستور Show ip ospf neighbor لیست همسایه های روتر مرکزی را می بینید که در تصویر زیر نمایش داده می شود:

پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت چهارم

همانطور که در تصویر می بینید RID روتر همان IP مربوط به اینترفیس Loopback می باشد.

همچنین در قسمت state وضعیت همسایگی را نشان می دهد که در حالت Full قرار دارد.

خط تیره بعد از Full نشان دهنده نوع شبکه PTP می باشد و در آن انتخاب DR و BDR نداریم. اگر با دستور زیر نوع شبکه را برای پورت سریال 2 روتر دفتر مرکزی و پورت سریال 0 روتر کرج را به حالت Broadcast قرار دهیم خروجی دستور بالا به شکل زیر خواهد شد و می بینید که روتر مرکزی به عنوان DR انتخاب شده است.

پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت چهارم

همچنین سایر اطلاعات مانند اینترفیسی که از طریق آن با روتر مقابل همسایه شده ایم و IP روتر همسایه و مدت زمان مربوط به Dead را نشان می دهد.

Authentication :

جهت فعال سازی Authentication از دستورات زیر استفاده می کنیم:

در اینجا این قابلیت را فقط بین دو روتر مرکزی و ولیعصر به صورت زیر فعال می کنیم:

روتر ولیعصر :

Valiasr(config)#interface Serial 0/0
Valiasr(config-if)#ip ospf authentication message-digest
Valiasr(config-if)#ip ospf authentication-key 123

روتر مرکزی :

markazi(config)#interface Serial 0/1
markazi(config-if)#ip ospf authentication message-digest
markazi(config-if)#ip ospf authentication-key 123

با استفاده از دستور زیر می توانیم وضعیت Authentication را برای یک پورت ببینیم :

Markazi#show ip ospf interface serial 0/1

خروجی دستور فوق به صورت زیر است :

پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت چهارم

امیدوارم که این سناریو برای درک بهتر این پروتکل مفید واقع شده باشد.

نویسنده : جعفر قنبری شوهانی

منبع : جزیره سیسکو وب سایت توسینسو

هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی می باشد

#احراز_هویت_در_ospf #پیکربندی_ospf_در_روتر_سیسکو #ospf_router_id_چیست #سناریوی_ospf #آموزش_پیاده_سازی_ospf_در_روتر_سیسکو #ospf_در_روتر_سیسکو #ospf_چیست #راه_اندازی_ospf_در_روتر_سیسکو
عنوان
1 پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت اول رایگان
2 پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت دوم رایگان
3 پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت سوم رایگان
4 پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت چهارم رایگان
5 پروتکل مسیریابی OSPF چیست و چگونه استفاده می شود؟ - قسمت پنجم رایگان
زمان و قیمت کل 0″ 0
11 نظر
mehran110

سپاسگزارم

ان شالله در تمام مراحل زندگی موفق و موید باشید

علی تمیجی

در مورد area بندی تصویر زیر که روتر ABR برای اتصال به area 1 که حکم backbone area را در تصویر زیر دارد .

چطور می تونم انجام بدم .

در ضمن یک جا خوندم که باید از virtual link استفاده بشه انجام دادم ولی روت ها به درستی کار نمی کنند .

ospf

جعفر قنبری شوهانی

Area 0 به عنوان Backbone Area است و همه Area ها باید به این Area متصل بشن

علی تمیجی

شرایط برقراری این ارتباط می تونه چطوری باشه مهندس .

چون ارتباط فیزیکی برای اینکه Area ها متصل بشن وجود نداره .

این روترهای ABR هستن که ارتباط به یکدیگر داره . یعنی به صورت Point to Point به یکدیگر متصل می شن .

من روش Virtual Link رو تست کردم ولی چون Area زیادی تو سناریو دارم نتونستم خوب جواب بگیرم .

یکی از روش هایی که خودم استفاده کردم و نتیجه گرفتم این بود که اومدم لینک ارتباطی که Area 1 به سایر Area ها متصل می شد رو تو همون Area 1 قرار دادم ( خطوط قرمز رنگ ) و شبکه اون ها رو Advertise کردم . و بدون مشکل کار می کرد و شبکه هام از هر جایی تو این سناریو می تونستم بهشون دسترسی داشته باشم .

حالا نمی دونم این کارم رو اصولی انجام دادم یا نه .

وب سایت توسینسو

جعفر قنبری شوهانی

برای اینکه سناریو رو بتونید راحت تر پیاده سازی کنید مرحله به مرحله اون پیاده سازی کنید

در مرحله اول Area 0 رو بسازید بعد یکی یکی سایر Area ها رو اضافه کنید

همینطور به این راحت تر پیاده سازی رو داشته باشید این پنچ قسمت مقاله رو بخونید بعد دقیقا همین سناریویی که گذاشتم رو پیاده سازی کنید بعد اونو تغییرش بدید یا سناریوهای جدید در نظر بگیرید

علی تمیجی

مراحل رو پیاده سازی کردم ولی با توجه به تصویر بالا Area1 من همان حکم Area 0 می باشد .

امکان اینکه مستقیم فضا های 4 و 3 و 2 را به 1 وصل کنم وجود ندارد .

باید ابتدا 4 به 3 متصل بشه و 3 نیز ارتباطش رو به 2 و سپس 2 به 1 متصل بشه .

جعفر قنبری شوهانی

area 1 شما حتی اگه شرایط area 0 رو داشته باشه بازم نمی تونه به عنوان area 0 عمل کنه حتما حتما شما باید area 0 داشته باشید

علی تمیجی

استاد در مورد کانفیگ های Area هایی که نمی تونن به صورت مشتقیم به Area 1 که در این مثال ما فرض می گیریم که همان Area 0 است . چطور بادید ست بشه .

منظورم اینکه مثلا Area 4 که باید ابتدا به 3 و 3 نیز به 2 و 2 نیز به 1 وصل بشه . در این صورت چطور باید Area های در این مثال به یکدیگر متصل بشن تا بتونن روت های خودشون رو به درستی Advertise کنن و به درستی این روتینگ پروتکل کار کنه .

جعفر قنبری شوهانی

دوست عزیز شما نمی تونید فرض بگیرید

Area 1 رو حذف و به جای اون Area 0 رو ایجاد کنید

سعید عزیزی

عالی مثل همیشه

الناز

با سلام وخسته نباشید

ممنون از مطالب جامعی که ارائه کردید. این سناریو به صورت Point to point هست.

خواستم بدونم امکانش هست یک سناریو در حالت Multiaccess را آموزش بدید؟

یعنی روتر DR و BDR و نحوه انتخاب بر اساس RID همانطور که توضیح دادید

خیلی ممنون

نظر شما
برای ارسال نظر باید وارد شوید.
از سرتاسر توسینسو
تنظیمات حریم خصوصی
تائید صرفنظر
×

تو می تونی بهترین نتیجه رو تضمینی با بهترین های ایران بدست بیاری ، پس مقایسه کن و بعد خرید کن : فقط توی جشنواره پاییزه می تونی امروز ارزونتر از فردا خرید کنی ....