تا %60 تخفیف خرید برای 5 نفر با صدور مدرک فقط تا
00 00 00
در توسینسو تدریس کنید

آموزش راه اندازی GRE Tunnel در روتر سیسکو

در قسمت قبل با مفاهیم تانل و کاربرد ها و ویژگی های آن آشنا شدیم و در این بخش می خواهیم به پیاده سازی تانل GRE بپردازیم با ما همراه باشید.

ایجاد تانل GRE در روتر سیسکو

ایجاد یک تانل GRE شامل چند مرحله می باشد که این مراحل به شرح زیر هستند :

  • مرحله 1 : در ابتدا یک اینترفیس تانل مجازی در Global Configuration با استفاده از دستور interface tunnel ID ایجاد کنید.
  • مرحله 2 : سپس در تنظیمات اینترفیس تانلی که ایجاد کرده اید یک آدرس IP با استفاده از دستور ip address ipaddress subnetmask اضافه کنید.
  • مرحله 3 : مبدا تانل را با استفاده از دستور tunnel source { interfaceid | ip address } براساس آدرس IP یا اینترفیس مشخص کنید.
  • مرحله 4 : مقصد تانل را با استفاده از دستور tunnel destination ip_address مشخص کنید.
  • مرحله 5 : مراحل ذکر شده را برای روتر مقابل تکرار کنید.

GRE Configuration Example

برای اینکه با مراحل تنظیم تانل GRE بیشتر و بهتر آشنا شوید یک سناریو برای GRE را اجرا می کنیم.

پیاده سازی تانل GRE در روترهای سیسکو

به تصویر بالا توجه کنید یک سازمان را در نظر بگیرید که دارای دو سایت است که از طریق Service Provider ارتباط بین این دو سایت را برقرار کرده است حال این سازمان می خواهد از یک پروتکل مسیریابی دینامیک مثل EIGRP برای شبکه خود استفاده کند.

همانطور که در تصویر می بینید بین دو سایت چند روتر وجود دارد و ارتباط بین دو روتر سازمان به صورت مستقیم نیست و همانطور که می دانید یکی از شرایط برقراری رابطه همسایگی advertise یک شبکه تو هر دو روتر می باشد که در اینجا روتر R1 شبکه های 192.168.1.0 و 192.168.12.0 را دارد و روتر R4 شبکه های 192.168.4.0 و 192.168.34.0 را دارد و همانطور که می بینید این دو روتر شبکه مشترکی برای برقراری همسایگی خود ندارند.

راه حل برطرف کردن این مشکل استفاده از تانل است که یک شبکه مجازی به صورت Point to Point بین دو روتر R1 و R4 ایجاد کند و باعث شود که هر دو روتر دارای یک شبکه مشترک شوند.نکته : برای ایجاد تانل لازم است که دو روتر بتوانند با یکدیگر ارتباط داشته باشند برای اینکار می توان از Static route استفاده کرد که در این سناریو روی روتر R1 دستور زیر را برای ایجاد Static Route مورد نظر خود وارد می کنیم.

R1(config)#ip route 192.168.34.0 255.255.255.0 192.168.12.2

روی روتر R2 نیز برای Static Route دستور زیر را وارد می کنیم.

R4(config)#ip route 192.168.12.0 255.255.255.0 192.168.34.3

در ابتدا روتر R1 را تنظیم می کنیم که دستورات آن به صورت زیر است:

R1(config)#interface tunnel 1
R1(config-if)#ip address 192.168.14.4 255.255.255.0
R1(config-if)#tunnel source fastEthernet 1/0
R1(config-if)#tunnel destination 192.168.34.4

همانطور که می بینید در ابتدا یک اینترفیس تانل ایجاد شده است و به آن یک IP اختصاص داده شده است سپس مبدا این تانل را برابر اینترفیس fastethernet 1-0 قرار داده شده و مقصد تانل را برابر 192.168.12.1 قرار داده شده است این IP مربوط به اینترفیس fastethernet 1-0 روتر R4 است. نکته که اینجا حائز اهمیت است این است که این روتر بتواند با این IP ارتباط داشته باشد تا بتواند ارتباط تانل را برقرار کند.سپس روتر R4 را با دستورات زیر تنظیم می کنیم :

R4(config)#interface tunnel 1
R4(config-if)#ip address 192.168.14.1 255.255.255.0
R4(config-if)#tunnel source fastEthernet 1/0
R4(config-if)#tunnel destination 192.168.12.1

دستورات استفاده شده برای روتر R4 مشابه روتر R1 است فقط تفاوت آن در IP مقصد تانل است که در اینجا IP اینترفیس fastethernet 1-0 روتر R1 استفاده می شود.

  • نکته : از دستور tunnel mode gre ip برای تعیین نوع GRE برای تانل استفاده می شود اما چون به صورت پیش فرض اینترفیس تانل که ایجاد می شود در این حالت قرار می گیرد نیاز به وارد کردن این دستور نیست.

حال تانل ایجاد شده است و همینطور که در تصویر زیر می بینیم در وضعیت UP قرار گرفته است.

پیاده سازی تانل GRE در روترهای سیسکو

با استفاده از دستور show interface tunnel 1 می توانیم وضعیت تانل را با جزئیات بیشتری ببینیم.

پیاده سازی تانل GRE در روترهای سیسکو

همانطور که در تصویر مشخص شده است وضعیت تانل در حالت UP قرار دارد. آدرس تانل 192.168.14.1 می باشد. پهنای باند آن 100 Kbps می باشد. نوع کپسوله تانل می باشد. مبدا و مقصد تانل مشخص شده است. پروتکل تانل GRE و پروتکل Transport را IP مشخص کرده است.حال اگر پروتکل مسیریابی EIGRP را پیاده سازی کنیم دو روتر R1 و R4 می توانند از طریق تانل همسایه شوند. در تصویر زیر نشان داده شده است که روتر R1 از طریق Tunnel 1 با روتر R4 همسایه شده است.

پیاده سازی تانل GRE در روترهای سیسکو

همچنین اگر از PC1 بخواهیم PC2 را trace بگیریم خروجی به شکل زیر خواهد بود.

پیاده سازی تانل GRE در روترهای سیسکو

همانطور که در تصویر می بینید تنها روترهای R1 و R4 در مسیر ما نمایش داده شده است و روترهای R2 و R3 در اینجا دیده نمی شوند و دلیل آن استفاده از تانل می باشد.برای درک بهتر و دقیق تر مبحث GRE یک ویدیو در این زمینه آماده خواهد شد و در اختیار شما عزیزان قرار خواهد گرفت. موفق ، پیروز و ITPro باشید.

نویسنده : جعفر قنبری شوهانی

منبع : جزیره سیسکو وب سایت توسینسو

هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی می باشد.

#نحوی_تانل_زدن #تنظیم_gre #دستورات_gre #آموزش_راه_اندازی_gre_در_روتر_سیسکو #یک_مثال_برای_gre #تانل_gre_چیست
عنوان
1 GRE چیست؟ بررسی کاربرد تانل GRE و کاربردهایش رایگان
2 آموزش راه اندازی GRE Tunnel در روتر سیسکو رایگان
زمان و قیمت کل 0″ 0
نظر شما
برای ارسال نظر باید وارد شوید.
9 نظر
افرادی که این مطلب را خواندند مطالب زیر را هم خوانده اند
تنظیمات حریم خصوصی
تائید صرفنظر