آموزش مقدماتی سیسکو ( CCNA ) | دستورات اولیه | VLAN و DHCP

آموزش سیسکو و به ویژه آموزش دوره CCNA سیسکو به آسانی مطالعه چند مقاله و تبدیل شدن به یک کارشناس سیسکو نیست. شما باید مقاله و مطالب سطح وب را صرفا برای تکمیل اطلاعات سیسکویی خود مطالعه کنید و برای یادگیری اصولی سیسکو باید دوره های آموزشی CCNA و CCNP و CCIE را به ترتیب تخصص ، بصورت اصولی با استفاده از کتاب ، دوره های آموزشی سیسکو حضوری ، آنلاین و ویدیوهای آموزشی یاد بگیرید. این مقاله صرفا برای یادگیری مقدمات و پیدا کردن دید اولیه نسبت به تنظیمات اولیه سویچ و روتر سیسکو برای شما نوشته شده است و پیشنهاد می کنیم برای یادگیری اصولی سیسکو به دوره زیر مراجعه کنید :

دوره های شبکه، برنامه نویسی، مجازی سازی، امنیت، نفوذ و ... با برترین های ایران

آموزش مقدماتی سیسکو (CCNA) قسمت 1 : دستورات مقدماتی سیسکو

آشنایی با سوئیچ سیسکو

سوئیچ مانند یک ترمینال تمامی تجهیزات موجود در شبکه را به صورت توپولوژی استار به هم متصل می کند. تمامی پیام ها را از پورت هایش دریافت کرده و تنها به پورت مقصد ارسال می کند. برخلاف هاب که بسته را به همه پورت ها پخش همگانی یا Broadcast می کند.

پیشنیاز همه دوره های آموزشی سیسکو ، یادگیری دوره آموزش نتورک پلاس است

در واقع در مقایسه با هاب سوئیچ هوشمند است. سوئیچ می تواند بسته ها را پردازش کند. سوئیچی لایه 2 تا لایه 2 مدل OSI پیش می رود و آدرس سخت افزاری یا MAC address را در جدولی ذخیره می کند. این جدول شامل MAC آدرس فرستنده بسته و شماره پورت می باشد. به این ترتیب هر بسته ورودی را که دریافت می کند، با خواندن آدرس گیرنده و مراجعه به جدول، بسته را به پورت مقصد و سیستمی که به آن پورت متصل است می فرستد. سوئیچ در لایه بالاتر هم می تواند فعالیت کند، مثل سوئیچ های لایه 3.

پیشنهاد مطالعه : آموزش سیسکو را از کجا شروع کنیم؟ مسیر راه و ساختار دوره های سیسکو

آشنایی با روتر سیسکو

روتر در لایه سوم کار می کند. روتر شبکه های مختلف را به هم متصل می کند. در واقع سوئیچ تمام سیستم های موجود در یک شبکه با رنج آدرس یکسان را به هم متصل می کند و روتر ارتباط دو شبکه با رنج آدرس مختلف را به هم مرتبط می کند. روتر از آدرس IP در جدول خود استفاده می کند. به زبان ساده تر می گوید برای هر رنج IP آدرس شبکه های مختلفی که به آن متصل هستند از چه مسیری باید عبور کرد.

IOS چیست؟

سوئیچ و روتر بدون استفاده از یک سیستم عامل قدرتمند نمی توانند در شبکه به خوبی عمل کنند. سیستم عامل IOS مخصوص تجهیزات شرکت سیسکو می باشد. بدون وجود این سیستم عامل سخت افزار قادر به فعالیت نمی باشد. این سیستم عامل خدمات زیر را ارائه می کند:

  1. روتینگ و سوئیچینگ
  2. امنیت در دسترسی به منابع شبکه
  3. پیکربندی و قابلیت توسعه شبکه

روش های اتصال به سوئیچ و روتر

وب سایت توسینسو

معرفی سطوح مختلف رابط کاربری در IOS سیسکو

رابط کاربری CLI دیوایس سیسکو از یک ساختار سلسله مراتبی یا hierarchial بهره می برد. ساختار فوق کاربران را ملزم می نماید که برای انجام هر نوع عملیات خاص به یک mode خاص وارد شوند. مثلا برای پیکربندی باید وارد مد پیکربندی (configuration mode)شویم.

وب سایت توسینسو

نکات CLI یا خط فرمان IOS سیسکو

    1. تکمیل خودکار دستور با کلید Tab
    2. اجرا شدن دستور فقط با تایپ قسمتی از آن
    3. استفاده از ؟ جهت دریافت فهرست command ها
    4. استفاده از کلید ترکیبی CTRL+Shift+6 جهت رفع خطای Translating "x x x x" …domain server(255.255.255.255)
Switch> enable               یا                en
Switch# configure Terminal               یا              conf t
Switch# show startup config                یا              sho star

دستورات رمز گذاری روی کنسول پورت سویچ سیسکو

کابل کنسول را به سوئیچ متصل می کنیم و با یک نرم افزار مثل putty و استفاده از پورت com به آن متصل می شویم.

Switch>enable
Switch#Configure Terminal
Switch(config)# line console 0
Switch(config-line)# password cisco
Switch(config-line)# login
Switch(config-line)# exit

جهت حذف رمز ایجاد شده وارد سطح کنسول شده و قیل از دستور password ، no می زنیم

Switch(config-line)#no  password

تغییر نام سوئیچ

Switch(config)# hostname SW1

- رمز برای privilege mode

Switch(config)# enable password cisco

معرفی انواع حافظه در سوئیچ و روتر

دیوایس های سیسکو برای نگهداری سیستم عامل IOS و تنظیمات پیکربندی در حال اجرا و ذحیره شده و با بوت شدن خود سیستم عامل حافظه های مختلفی دارند.

وب سایت توسینسو

دستورات IOS جهت مشاهده اطلاعات و ذخیره سازی تنظیمات انجام شده

نمایش محتویات حافظه RAM

Switch#show running-config

نمایش حافظه NVRAM

Switch#show startup-config

نمایش محتویات FLASH

Switch#show flash

کپی و ذخیره کردن محتویات RAM در NVRAM

Switch#copy running-config startup-config

کپی و ذخیره کردن محتویات NVRAM در RAM

Switch#copy startup-config running-config

ایجاد پیام ورودی

Switch(config)#banner "Attention Message"

آموزش مقدماتی سیسکو (CCNA) قسمت 2 : مفاهیم و تنظیمات VLAN

یک شبکه Lan مجازی، در واقع یک شبکه محلی مجازی می باشد. هر شبکه محلی برای خودش یک محدوده پخش همگانی یا Broadcast دارد، که در این محدوده ترافیک شبکه محلی در حرکت است. در واقع وقتی شما یک شبکه Lan ایجاد می کنید، ترافیک پخش همگانی را به محدوده کوچکتری می شکنید، حال اگر بتوانیم با ایجاد شبکه مجازی درون همین شبکه محلی، محدوده Broadcast domain یا پخش همگانی را بشکنیم

می توانیم ترافیک شبکه را بهبود ببخشیم و ترافیک های مختلف شبکه را از هم جدا کنیم، به طور مثال ترافیک voice را از ترافیک data جدا کنیم که باعث می شود کیفیت تماس صوتی بهتری داشته باشیم.در سوئیچ های سیسکو به صورت پیش فرض vlan1 فعال می باشد و همه پورت ها در این vlan قرار دارند. با ایجاد vlan جدید و قرار دادن پورت ها در vlan های متفاوت سرعت و کارایی سوئیچ و شبکه افزایش می یابد.

Switch(config)# interface vlan 1
Switch(config-if)#IP address 192.168.0.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit or end

رمزگذاری پسورد (encryption) در سویچ و روتر سیسکو

در تجهیزات سیسکو وقتی با دستور show run تنظیمات انجام شده را مرور می کنیم، رمز هایی که برای console و telnet تنظیم کردیم، به صورت clear text و رمز نشده قابل مشاهده هستند. این موضوع شبکه ما را با تهدیدات جدی مواجه خواهد کرد. برای رفع این مشکل از سرویس password encryption استفاده می کنیم.

Switch(config)# enable password cisco
Switch(config)# service password-encryption

استفاده از secret برای line vty و line console

Switch(config)#username USER {secret/password} CISCO
Switch(config)#line vty 0 15
Switch(config-line)#login local
Switch(config)#line console 0
Switch(config-line)#login local

فعال سازی telnet بر روی سوئیچ سیسکو

به منظور ایجاد امکان ارتباط از راه دور و دسترسی غیر فیزیکی به تجهیزات سیسکو، می بایست telent را بر روی تجهیزات فعال کرد تا دیگر نیاز نباشد که به صورت فیزیکی به سوئیچ متصل شد. برای این منظور مراحل زیر را طی می کنیم:

1-	Set ip address on vlan
2-	Set parameters and terminals
3-	Set password to safe access
4-	Set IP on your device

Switch(config)# interface vlan 1
Switch(config-if)# ip address IP Subnet
Switch(config-if)# no shutdown
Switch(config-if)# exit

Switch(config)# line vty 0 15
Switch(config-line)# password CISCO
Switch(config-line)# login
Switch(config-line)# exit

Switch(config)# enable password CISCO

معرفی پورت های سوئیچ و نحوه تنظیم آنها

انواع سوئیچ از نظر تعداد پورت

  1. تعداد پورت ها در این سوئیچ ثابت بوده و قابل تغییر نیست. FIX – 13,16,24,48
  2. امکان افزایش پورت وجود دارد. Modular – 4500 , 6500

انواع سوئیچ از لحاظ سرعت –

  1. Ethernet 10 Mbps
  2. FastEthernet 100 Mbps
  3. Gigabit Ethernet 1000 Mbps
  4. Ten Gigabit Eternet 10000 Mbps

به هر پورت سوئیچ اینترفیس (interface) گفته می شود و بصورت پیش فرض تمامی پورت های سوئیچ بر خلاف پورت های روتر فعال می باشند. (no sh) شما می توانید برای اعمال تغییرات گروهی بر روی پورت های سوئیچ از دستور range استفاده کنید.

Switch(config)# interface TYPE MOD/NUM
Switch(config)# interface FastEthernet 0/1
Switch(config-if)# description Sample-config-port
Switch(config)# int range fastethernet 0/1-24

آموزش مقدماتی سیسکو (CCNA) قسمت 3 : DHCP و Port Sec

معرفی انواع روشهای ارسال Packet در شبکه

  1. Unicast: انتقال اطلاعات از یک نود به نود دیگر.
  2. Multicast: انتقال اطلاعات برای گروهی از نود ها.
  3. Broadcast: ارسال به تمامی نود های شبکه.

سوئیچ در شبکه چگونه فعالیت می کند؟

سوئیچ ها در لایه دوم مرجع OSI یا دیتا لینک با استفاده از مک آدرس فعالیت می کنند. هرگاه یک نود جدید به شبکه اضافه شود، یک بسته Broadcast برای همه ارسال می کند تا حضور خود را در شبکه اعلام کند. سوئیچ با دریافت این بسته، آن را برای همه پورت های خود پخش می کند. بسته های اطلاعاتی که به سوئیچ وارد می شوند، در بافر ذخیره می گردند.

در هر بسته آدرس های MAC در قسمت فریم نگهداری می شوند. سوئیچ این آدرس ها را خوانده و در جدول خود MAC Table ذخیره می کند. در هنگام آدرس دهی سوئیچ مک آدرس مبدا و مقصد را چک کرده و در صورتی که آدرس مقصد را در جدول مک آدرس های خود داشت برای مقصد ارسال می کند.

1-سوئیچ های packet-based برای تعیین مسیر ترافیک از یکی از روش های زیر استفاده می کند:

  • Cut through: در این روش، سوئیچ آدرس های MAC را به محض دریافت بسته می خواند و سپس 6 بایت MAC اطلاعات مربوط به آدرس را ذخیره کرده و با وجود اینکه ما بقی بسته ها در حال رسیدن به سوئیچ می باشند، اقدام به ارسال بسته مذکور به سمت نود مقصد می نماید.
  • Store and forward: ابتدا تمام اطلاعات داخل بسته را دریافت و نگهداری می کند و قبل از ارسال بسته مورد نظر به دنبال خطای CRC (cyclic redundancy check) و یا مشکلات دیگر می گردد. اگر بسته حاوی خطا باشد، حذف می شود. در غیراینصورت با توجه به آدرس گیرنده، آن را به مقصد ارسال می کند.

بیشتر سوئیچ ها از هر دو روش بالا استفاده می کنند. روش اول توانایی کشف خطا را ندارد، اما از سرعت بالایی برخوردار است.

  • Fragment free: در این روش که مانند روش اول است، سوئیچ قبل ارسال بسته، 64 بایت اول را به علت اینکه اکثر خطاها در طول اولین 64 بایت اتفاق می افتد، نگهداری می کند. سوئیچ ها کمتر از این روش استفاده می کنند.

Port Security چیست؟

امنیت، امروزه امنیت یکی از مباحث اصلی و جداناپذیر در دنیای اطلاعات و شبکه می باشد. یکی از مسائلی که شما به عنوان یک مدیر شبکه همواره باید مدنظر داشته باشید، کنترل دسترسی افراد به شبکه می باشد. شما با استفاده از port security می توانید زمینه ای را فراهم کنید تا هر کسی نتواند به راحتی هر سیستمی را ( لپ تاپ شخصی ) به شبکه متصل کند.

یکی از روش های کنترل ترافیک در لایه 2 ، port security می باشد. شما به تعداد خاصی از آدرس های مک، اجازه اتصال به پورت را می دهید. اگر مک آدرس دیگری بخواهد به پورت متصل شود، پورت به صورت خودکار غیرفعال می شود و باید توسط ادمین شبکه مجددا فعال گردد.

Switch(config)# interface fastethernet 0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport port-security
Switch(config-if)# switchport port-security mac-address {0002.97d6.8035|sticky}
Switch(config-if)# switchport port-security maximum {1-132}
Switch(config-if)# switchport port-security violation {shutdown|restrict|protect}
  • Sticky: به محض اینکه اولین دستگاه به پورت متصل شود، MAC address آن ذخیره می گردد.
  • Maximum number: تعداد دستگاه هایی که می توانند از این پورت استفاده کنند.
  • Violation: وقتی دستگاه غیر مجاز به پورت متصل شود، چه عکس العملی انجام شود.

DHCP چیست؟

همانطور که می دانید در شبکه از آدرس IP برای آدرس دهی استفاده می شود، در شبکه های کوچک می توانیم آدرس های IP را به صورت دستی تنظیم و مدیریت کنیم، اما با گسترش تعداد نود های شبکه نیاز به یک سرویس جهت ارائه IP به سیستم های موجود در شبکه داریم. سرویس DHCP مسئولیت ارائه IP و جلوگیری از conflict آدرس ها را بر عهده دارد.

Switch(config)# interface vlan 1
Switch(config-if)# ip address IP ADDRESS NET MASK
Switch(config-if)# no shutdown
Switch(config-if)# exit

Switch(config)# ip excluded-address {start ip address end ip address}
Switch(config)# ip dhcp pool POOL NAME
Switch(dhcp-config)# network NET ID NET MASK
Switch(dhcp-config)# default-router IP ADDRESS
Switch(dhcp-config)# dns-server IP ADDRESS
Switch(dhcp-config)# ctrl+z
Switch# show ip dhcp binding
  • آموزش سیسکو را از کجا شروع کنیم؟

    بهترین دوره برای شروع سیسکو ، دوره آموزشی CCNA روتینگ و سویچینگ است و بعد از آن تقریبا مسیر راه شما برای ورود به دنیای سیسکو باز می شود
  • دوره های سیسکو چه چیزهایی هستند؟

    از مهمترین عناوین دوره های سیسکو می توان به دوره CCNA ، دوره CCNP ، دوره CCIE ، دوره CCA و دوره CCDA اشاره کرد که هر کدام برای خودشان گرایش های تخصصی مختلفی دارند

نظرات