محمد نصیری
بنیانگذار توسینسو ، هکر کلاه سفید ، کارشناس امنیت اطلاعات و ارتباطات و عاشق طبیعت

آموزش راه اندازی Static Route در روترهای سیسکو بصورت سناریو

چگونه Static Route یا روت دستی بنویسیم؟ در مطالب قبلی در وب سایت در خصوص اینکه Static Route چیست و تفاوت آن با Default Route و Dynamic Routing چیست صحبت کردیم ، اما فراموش نکنیم که توسینسو هیچوقت به مطرح کردن مفاهیم بسنده نمی کند و در این مطلب آموزشی قصد داریم به شما یاد بدهیم که چگونه Static Route را روی روترهای سیسکو اضافه کنیم ، فقط از شما خواهش می کنیم بعد از کپی کردن مطلب حتما نام توسینسو و اگر دوست داشتید نویسنده را در وب سایت خود قرار دهید ، به هر حال Static Route ها در دستورات IOS روتر سیسکو به دو شکل زیر تعریف می شوند :

دوره های شبکه، برنامه نویسی، مجازی سازی، امنیت، نفوذ و ... با برترین های ایران
Router(config)#ip route destination_network subnet_mask default_gateway [administrative_distance] [permanent] 

یا

Router(config)# ip route destination_network subnet_mask interface_to_exit [administrative_distance] [permanent]

شاید برخی موارد در دستورات بالا مبهم به نظر برسد بنابراین همه قسمت ها را توضیح می دهم ، دستور اصلی که ip route است و مشخص است که قرار است برای ایجاد static route ابتدا این دستور را باید وارد کنیم ، در قسمت destination_network شما باید آدرس شبکه مقصدی که قرار است به سمت آن route داشته باشید را قرار بدهید از ترجمه کلمه کاملا مشخص است .

در قسمت subnet_mask باید subnetmask مربوط به شبکه مقصد را وارد کنید ، در قسمت default gateway قطعا آدرس default gateway برای خروج ترافیک از شبکه را مشخص می کنید ، در در قسمت interface_to_exit شما می توانید ترافیک را به جای Gateway از یک Interface مشخص عبور دهید

و در خصوص Administrative Distance هم که قبلا نکته ای در توسینسو در همین لینک قرار داده ایم می توانید عدد مورد نظر را در این قسمت وارد کنید. کلمه permanent یا persistent باعث می شود route ای که شما اضافه می کنید در routing table روتر حتی بعد از خاموش و روشن شدن یا دچار مشکل شدن روتر باقی بماند و دقیقا مشابه کاری را انجام می دهد که سویچ –p در دستور route add ویندوز انجام می دهد.

ایجاد لابراتوار تمرینی برای Static Route

در تصویر پایین که بصورت اختصاصی برای سناریوهای انجمن تخصصی فناوری اطلاعات ایران طراحی شده است شما دیاگرام سناریوی لابراتوار Static Route را مشاهده می کنید. ما در این سناریو سه عدد روتر به همراه سه عدد سویچ و سه عدد سیستم Host داریم که به هم به شکل زیر متصل شده اند.

اسامی روترها و Host ها و آدرس های IP هر کدام از آنها در تصویر به خوبی نمایش داده شده است ، Interface های روترها و سویچ هایی که به هم متصل شده اند نیز به خوبی نمایش داده شده است. سناریوی ما بر اساس همین شکل در نرم افزار Packet Tracer یا هر لابراتوار واقعی و مجازی دیگری قابل پیاده سازی است.

سناریوی Static Routing



اگر با ارتباطات کنسول روتر آشنایی ندارید می توانید با استفاده از این آموزش که چگونه به پورت سریال روتر خود با استفاده از پورت کنسول متصل شویم ؟ مراجعه کنید. یا اگر پورت کنسول را دارید می توانید از طریق آموزش چگونه با استفاده از PUTTY به Terminal روتر خود دسترسی پیدا کنیم ؟ مراجعه کنید. البته توجه کنید که شما در نرم افزارهای مجازی ساز اینقدر دچار مشکل نخواهید شد اما با توجه به اینکه همه این آموزش ها قبلا در انجمن تخصصی فناوری اطلاعات ایران قرار گرفته است بهتر است اصولی برخورد کنیم.

قرار دادن Hostname و IP Address برای ITPRO-R1

با استفاده از پورت کنسول به روتر اول متصل شوید و از طریق دستورات IOS اسم آن را به ITPRO-R1 به شکل زیر تغییر دهید :

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname ITPRO-R1
ITPRO-R1(config)#

با استفاده از دستور زیر وارد configuration mode مربوط به fast ethernet interface fa0//0 شوید و بر روی ITPRO-R1 آدرس IP را به شکل 172.16.0.1//16 تنظیم کنید :

ITPRO-R1>enable
ITPRO-R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R1(config)#interface fa0/0
ITPRO-R1(config-if)#ip address 172.16.0.1 255.255.0.0
ITPRO-R1(config-if)#no shutdown

با استفاده از دستور زیر وارد configuration mode مربوط به serial interface s0//0 روتر ITPRO-R1 شوید و آدرس IP این Interface را 172.17.0.1//16 قرار دهید. همچنین با استفاده از دستور clock rate عدد مربوطه را برای s0//0 به شکل 64000 قرار دهید تا در نقش یک DCE عمل کند. برای اطلاعات بیشتر در این خصوص می توانید به تفاوت DCE و DTE در همین انجمن مراجعه کنید.

ITPRO-R1>enable
ITPRO-R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R1(config)#interface s0/0
ITPRO-R1(config-if)#clock rate 64000
ITPRO-R1(config-if)#ip address 172.17.0.1 255.255.0.0
ITPRO-R1(config-if)#no shutdown

با استفاده از دستور copy running-config startup-config در enable mode تنظیمات را ذخیره کنید . اگر می خواهید در این خصوص اطلاعات بیشتری به دست بیاورید به این نکته در خصوص تفاوت running config و startup config در چیست در توسینسو مراجعه کنید.

قراردادن Hostname و IP Address برای ITPRO-R2

به پورت کنسول روتر دوم متصل شوید و با استفاده از دستورات IOS به شکل زیر Hostname روتر را به ITPRO-R2 تغییر دهید :

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname ITPRO-R2
ITPRO-R2(config)#

با استفاده از دستور زیر وارد configuration mode مربوط به fast ethernet interface fa0//0 شوید و بر روی ITPRO-R1 آدرس IP را به شکل 172.18.0.1//16 تنظیم کنید :

ITPRO-R2>enable
ITPRO-R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R2(config)#interface fa0/0
ITPRO-R2(config-if)#ip address 172.18.0.1 255.255.0.0
ITPRO-R2(config-if)#no shutdown

با استفاده از دستور زیر در configuration mode مربوط به serial interface s0//0 این روتر آدرس IP روتر ITPRO-R2 را به شکل 172.17.0.2//16 قرار بدهید.

ITPRO-R2>enable
ITPRO-R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R2(config)#interface s0/0
ITPRO-R2(config-if)#ip address 172.17.0.2 255.255.0.0
ITPRO-R2(config-if)#no shutdown

با استفاده از دستورات زیر در configuration mode مربوط به serial interface s0//1 بر روی روتر ITPRO-R2 آدرس IP این interface را به 172.19.0.1//16 تغییر دهید. همچنین با استفاده از دستور clock rate عدد مربوطه را برای s0//1 به شکل 64000 قرار دهید تا در نقش یک DCE عمل کند. برای اطلاعات بیشتر در این خصوص می توانید به تفاوت DCE و DTE در همین انجمن مراجعه کنید.

ITPRO-R2>enable
ITPRO-R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R2(config)#interface s0/1
ITPRO-R2(config-if)#clock rate 64000
ITPRO-R2(config-if)#ip address 172.19.0.1 255.255.0.0
ITPRO-R2(config-if)#no shutdown

با استفاده از دستور copy running-config startup-config در enable mode تنظیمات را ذخیره کنید .

قرار دادن Hostname و IP Address برای ITPRO-R3

از طریق کابل کنسول به روتر ITPRO-R3 متصل شوید و با استفاده از دستورات IOS زیر Hostname را به ITPRO-R3 تغییر دهید :

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname ITPRO-R3
ITPRO-R3(config)#

با استفاده از دستورات IOS زیر در محیط configuration mode مربوط به fast ethernet interface fa0//0 روتر ITPRO-R3 تنظیمات آدرس IP آن را به 172.20.0.1//16 تغییر دهید .

ITPRO-R3>enable
ITPRO-R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R3(config)#interface fa0/0
ITPRO-R3(config-if)#ip address 172.20.0.1 255.255.0.0
ITPRO-R3(config-if)#no shutdown

با استفاده از دستور IOS زیر configuration mode مربوط به serial interface s0//1 را روی روتر ITPRO-R3 باز کنید و تنظیمات آدرس IP آن را به شکل زیر بصورت 172.19.0.2//16 قرار دهید.

ITPRO-R3>enable
ITPRO-R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R3(config)#interface s0/1
ITPRO-R3(config-if)#ip address 172.19.0.2 255.255.0.0
ITPRO-R3(config-if)#no shutdown

با استفاده از دستور copy running-config startup-config در enable mode تنظیمات را ذخیره کنید.

تنظیمات Static Route مربوط به ITPRO-R1

به پورت کنسول ITPRO-R1 متصل شوید و با استفاده از دستورات IOS زیر تنظیمات static Routing را بر روی آن انجام دهید. دستور ip route در دستور پایین به این معناست که برای دسترسی پیدا کردن به شبکه های 172.18.0.0//16 و 172.19.0.0//16 و 172.20.0.0//16 بسته های اطلاعاتی یا Packet ها باید از آدرس IP مربوط به Gateway ی 172.17.0.2 عبور داده شوند. شبکه های 172.16.0.0//16 و 172.17.0.0//16 بصورت مستقیم به ITPRO-R1 متصل شده اند.

ITPRO-R1>enable
ITPRO-R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R1(config)#ip route 172.18.0.0 255.255.0.0 172.17.0.2
ITPRO-R1(config)#ip route 172.19.0.0 255.255.0.0 172.17.0.2
ITPRO-R1(config)#ip route 172.20.0.0 255.255.0.0 172.17.0.2

با استفاده از دستور copy running-config startup-config در enable mode تنظیمات را ذخیره کنید . برای مشاهده routing table موجود بر روی ITPRO-R1 می توانید از دستور show ip route به شکل زیر استفاده کنید :

ITPRO-R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C    172.16.0.0/16 is directly connected, FastEthernet0/0
C    172.17.0.0/16 is directly connected, Serial0/0
S    172.18.0.0/16 [1/0] via 172.17.0.2
S    172.19.0.0/16 [1/0] via 172.17.0.2
S    172.20.0.0/16 [1/0] via 172.17.0.2

حرف S که در ابتدای برخی از route ها مشاهده می شود به معنای این است که یک static route به routing table اضافه شده است و این route نیز Static می باشد و حرف C که در کنار برخی از خط های routing table مشاهده می شود به معنای این است که این شبکه بصورت مستقیم به interface های روتر متصل شده است و به معنای directly Connected network می باشد.

تنظیمات Static Route مربوط به ITPRO-R2

با استفاده از پورت کنسول به روتر ITPRO-R2 متصل شوید و با استفاده از دستورات IOS زیر تنظیمات Static Routing را بر روی آن انجام دهید. دستور ip route ای که در پایین مشاهده می کنید به این معناست که اگر می خواهید به شبکه ی 172.16.0.0//16 متصل شوید Packet های خود را به سمت gateway ای به آدرس 172.17.0.1 ارسال کنید و اگر می خواهید به شبکه 172.20.0.0.//16 متصل شوید Packet های خود را به Gateway ای به آدرس 172.19.0.2 ارسال کنید . شبکه های 172.17.0.0//16 و 172.18.0.0//16 و 172.19.0.0. بصورت مستقیم به روتر متصل شده اند.

ITPRO-R2>enable
ITPRO-R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R2(config)#ip route 172.16.0.0 255.255.0.0 172.17.0.1
ITPRO-R2(config)#ip route 172.20.0.0 255.255.0.0 172.19.0.2

با استفاده از دستور copy running-config startup-config در enable mode تنظیمات را ذخیره کنید . برای مشاهده routing table موجود بر روی ITPRO-R2 می توانید از دستور show ip route به شکل زیر استفاده کنید :

ITPRO-R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
S    172.16.0.0/16 [1/0] via 172.17.0.1
C    172.17.0.0/16 is directly connected, Serial0/0
C    172.18.0.0/16 is directly connected, FastEthernet0/0
C    172.19.0.0/16 is directly connected, Serial0/1
S    172.20.0.0/16 [1/0] via 172.19.0.2

حرف S که در ابتدای برخی از route ها مشاهده می شود به معنای این است که یک static route به routing table اضافه شده است و این route نیز Static می باشد و حرف C که در کنار برخی از خط های routing table مشاهده می شود به معنای این است که این شبکه بصورت مستقیم به interface های روتر متصل شده است و به معنای directly Connected network می باشد.

تنظیمات Static Route مربوط به ITPRO-R3

به پورت کنسول روتر ITPRO-R3 متصل شوید و با استفاده از دستورات IOS زیر تنظیمات Static Routing را انجام دهید.دستور ip route ای که در پایین نشان داده شده است به این معنا می باشد که اگر می خواهید به شبکه های 172.17.0.0//16 و 172.17.0.0//16 متصل شوید Packet های شما باید از طریق gateway ای به آدرس 172.19.0.1 عبور داده شوند.. شبکه های 172.19.0.0//16 و 172.20.0.0//16 بصورت مستقیم به روتر ITPRO-R3 متصل شده اند.

Router03>enable
Router03#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router03(config)#ip route 172.16.0.0 255.255.0.0 172.19.0.1
Router03(config)#ip route 172.17.0.0 255.255.0.0 172.19.0.1
Router03(config)#ip route 172.18.0.0 255.255.0.0 172.19.0.1

با استفاده از دستور copy running-config startup-config در enable mode تنظیمات را ذخیره کنید . برای مشاهده routing table موجود بر روی ITPRO-R3 می توانید از دستور show ip route به شکل زیر استفاده کنید :

ITPRO-R3#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
S    172.16.0.0/16 [1/0] via 172.19.0.1
S    172.17.0.0/16 [1/0] via 172.19.0.1
S    172.18.0.0/16 [1/0] via 172.19.0.1
C    172.19.0.0/16 is directly connected, Serial0/1
C    172.20.0.0/16 is directly connected, FastEthernet

حرف S که در ابتدای برخی از route ها مشاهده می شود به معنای این است که یک static route به routing table اضافه شده است و این route نیز Static می باشد و حرف C که در کنار برخی از خط های routing table مشاهده می شود به معنای این است که این شبکه بصورت مستقیم به interface های روتر متصل شده است و به معنای directly Connected network می باشد.

تست برقراری ارتباط بین شبکه ها با استفاده از دستور Ping

برای اینکه مطمئن بشوید که ارتباط بین شبکه های شبکه برقرار شده است می توانید با استفاده از دستور ping در ITPRO-Host01 به آدرس 172.16.0.10//16 و ping کردن آدرس ITPRO-Host03 به آدرس 172.20.0.10//16 و دریافت Reply درست از ارتباط درست شبکه ها مطمئن شوید ، در زیر نتیجه این دستور را مشاهده می کنید که نشان از درست انجام شدن عملیات routing در شبکه ها دارد :

C:\>ping 172.20.0.10
Pinging 172.20.0.10 with 32 bytes of data:
Reply from 172.20.0.10: bytes=32 time=125ms TTL=125
Reply from 172.20.0.10: bytes=32 time=176ms TTL=125
Reply from 172.20.0.10: bytes=32 time=187ms TTL=125
Reply from 172.20.0.10: bytes=32 time=187ms TTL=125
Ping statistics for 172.20.0.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 172ms, Maximum = 235ms, Average = 195ms

نتیجه دستور بالا به معنای این است که static route بر روی هر سه روتر بصورت درست پیکربندی شده است و ارتباط بین شبکه ها برقرار است.

چگونه Default Route را در روترهای سیسکو پیکربندی کنیم؟

با استفاده از قالب دستوری زیر شما می توانید Default route ها را پیکربندی کنید ، در سناریوی بالا این مورد چندان کاربردی ندارد :

 Router(config)#ip route 0.0.0.0 0.0.0.0 default_gateway [administrative_distance] [permanent]
یا
 Router(config)# ip route 0.0.0.0 0.0.0.0 interface_to_exit [administrative_distance] [permanent] 

امیدوارم مورد توجه شما قرار گرفته باشد .

  • روتینگ دستی یا Static Route چیست؟

    اگر شما برای مسیریابی پروتکل IP در روتر و سویچ به جای استفاده از پروتکل های مسیریابی مثل RIP و OSPF و ... بصورت دستی مسیرها را مشخص کنید ، در اصطلاح Static Route یا مسیر دستی وارد کرده اید
  • آیا در ویندوز هم می توان Static Route نوشت؟

    بله ، حتی ویندوز و لینوکس و ... هم می توانند Static Route داشته باشند و بصورت دستی مسیر رسیدن به یک هدف تعیین بشود

محمد نصیری
محمد نصیری

بنیانگذار توسینسو ، هکر کلاه سفید ، کارشناس امنیت اطلاعات و ارتباطات و عاشق طبیعت

هکر با کلاه ، کارشناس امنیت اطلاعات و ارتباطات و کشف جرائم رایانه ای ، بیش از 12 هزار ساعت سابقه تدریس در بیش از 40 سازمان دولتی ، خصوصی و نظامی ، علاقه مند به یادگیری بیشتر و عاشق محیط زیست ، عضو کوچکی از مجموعه توسینسو

نظرات