در توسینسو تدریس کنید

و

با دانش خود درآمد کسب کنید

آموزش روشهای بکاپ گیری (Backup) از تجهیزات سیسکو قسمت 2

در مقاله قبلی از سری مقالات روش های Backup گیری از تجهیزات شبکه سیسکو ، شما را با روش های مختلفی که برای Backup گیری تحت شبکه تجهیزات شبکه سیسکو وجود دارد آشنا کردیم. قرار بر این بود که در ادامه سری مقالات در خصوص هر یک از روش ها توضیحاتی نوشته شده و بصورت عملی Backup گیری را انجام دهیم. در این مقاله شما را با روش Backup گیری از تنظیمات روتر و سویچ و ذخیره کردن Backup در حافظه NVRAM آشنا خواهیم کرد.

همانطور که قبلا هم اشاره شد حافظه NVRAM تنظیمات پیکربندی سویچ ها و روترها را در خود نگه می دارد تا در صورت Reload شدن و یا خاموش و روشن شدن دستگاه این تنظیمات همچنان به کار خود ادامه بدهند.در ادامه ما اینکار یا بهتر بگوییم این سناریو را بر روی یک روتر انجام می دهیم و از تنظیمات آن بر روی NVRAM بک آپ تهیه می کنیم . مشابه همین دستورات را می توانید در سویچ ها نیز استفاده کنید.


Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#host
Router(config)#hostname itpro
itpro(config)#

در خط پنجم از دستورات بالا ابتدا نام روتر را به itpro تغییر می دهیم

itpro(config)#exit 

%SYS-5-CONFIG_I: Configured from console by console
itpro#show running-config 
Building configuration...

Current configuration : 646 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname itpro
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end


itpro#

پس از تغییر نام روتر به itpro می توانیم با استفاده از دستوری که در خط چهارم قسمت بالا استفاده شد محتویات NVRAM را مشاهده کنیم.

itpro#
itpro#show startup-config 
startup-config is not present
itpro#

در قسمت بالا همانطور که مشاهده میکنید با دستوری که در خط شماره 2 وارد کرده ایم می توان محتویات درون nv ram را مشاهده کرد اما به دلیل اینکه هیچ چیزی در nv ram قرار ندارد خروجی که در خط 3 مشاهده می کنید را ایجاد خواهد.

itpro#copy running-config startup-config 
Destination filename [startup-config]? 
Building configuration...
[OK]
itpro#

در قسمت قبل مشاهده کردید که هیچ چیزی در nv ram قرار نداشت برای اینکه ما بتوانیم محتویات درون ram را درون nv ram ذخیره کرد باید از دستوری که در خط 1 وارد شده استفاده کرد و با انجام اینکار دقیقا هر آنچه که در ram وجود دارد در nv ram وجود خواهد داشت.

itpro#show startup-config 
Using 646 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname itpro
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end


itpro#

در بالا مشاهده می کنید که اینبار با دستور خط 1 که همانطور که گفته شد برای دیدن محتویات nv ram است خروجی به ما خواهد داد که دقیقا مشابه همان چیزی است که درون ram قرار دارد.

itpro#reload 
Proceed with reload? [confirm]
%SYS-5-RELOAD: Reload requested by console. Reload Reason: Reload Command.

System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
Copyright (c) 2000 by cisco Systems, Inc.
PT 1001 (PTSC2005) processor (revision 0x200) with 60416K/5120K bytes of memory

Self decompressing the image :
########################################################################## [OK]

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706



Cisco Internetwork Operating System Software
IOS (tm) PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 27-Apr-04 19:01 by miwang

PT 1001 (PTSC2005) processor (revision 0x200) with 60416K/5120K bytes of memory
.
Processor board ID PT0123 (0123)
PT2005 processor: part number 0, mask 01
Bridging software.
X.25 software, Version 3.0.0.
4 FastEthernet/IEEE 802.3 interface(s)
2 Low-speed serial(sync/async) network interface(s)
32K bytes of non-volatile configuration memory.
63488K bytes of ATA CompactFlash (Read/Write)

Press RETURN to get started!


%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to administratively down

%SYS-5-CONFIG_I: Configured from console by console


itpro>

پس از انجام تمامی تنظیمات گفته شده در این قسمت با استفاده از دستوری که در خط 1 قسمت قبلی وارد کردیم ، روتر خود را Reload یا خاموش و روشن می کنیم . با توجه به اینکه در این روش ما یک Backup از پیکربندی هایی که در RAM وجود دارد را بر روی NVRAM کپی کرده ایم ، پس از روشن شدن روتر و Load شدن IOS مشاهده می کنیم که همچنان نام روتر مورد نظر ما itpro می باشد و این بدین معناست که تنظیمات ما به حالت اولیه برنگشته اند و مجددا تنظیمات خود را می توانیم ادامه بدهیم.

در این مقاله شما با روش Backup گیری از RAM و قرار دادن آن در NVRAM آشنا شدید ، البته نکات مشکل ساز این مسئله را در مقاله قبلی ذکر کردیم و گفتیم که اینگونه Backup گیری چندان قابل اتکا نیست ، در مقاله بعدی از همین سری مقالات شما را با روش های Backup گیری با استفاده از FTP و TFTP آشنا خواهیم کرد . در صورت بروز هرگونه ابهام در خصوص مفاهیم و تنظیمات انجام شده بالا در ادامه مقاله مشکل را مطرح سازید

نویسنده : سینا رضایی

منبع : جزیره سیسکو وب سایت توسینسو

هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی می باشد

عنوان
1 آموزش روشهای بکاپ گیری (Backup) از تجهیزات سیسکو قسمت 1 رایگان
2 آموزش روشهای بکاپ گیری (Backup) از تجهیزات سیسکو قسمت 2 رایگان
3 آموزش روشهای بکاپ گیری (Backup) از تجهیزات سیسکو قسمت 3 رایگان
4 آموزش روشهای بکاپ گیری (Backup) از تجهیزات سیسکو قسمت 4 رایگان
زمان و قیمت کل 0″ 0
0 نظر

هیچ نظری ارسال نشده است! اولین نظر برای این مطلب را شما ارسال کنید...

نظر شما
برای ارسال نظر باید وارد شوید.
از سرتاسر توسینسو
تنظیمات حریم خصوصی
تائید صرفنظر
×

تو می تونی بهترین نتیجه رو تضمینی با بهترین های ایران بدست بیاری ، پس مقایسه کن و بعد خرید کن : فقط توی جشنواره پاییزه می تونی امروز ارزونتر از فردا خرید کنی ....