در توسینسو تدریس کنید

و

با دانش خود درآمد کسب کنید

آموزش راه اندازی EtherChannel به روش پیشنهادی سیسکو

سلام به تمامی دوستان توسینسویی

گاهی تو ساختن EtherChannel تو سوییچ های سیسکو مشکلاتی برای دوستان پیش میاد که دلیلش رعایت نکردن اصول ساخت EtherChannel هست و نه ایراد نرم افزاری یا سخت افزاری سوییچ.

من در این نکته مراحل ساخت اصولی EtherChannel که پیشنهاد خود سیسکو و جناب Narbik Kocharians مدرس و مؤلف کتاب های سیسکو هستند رو خدمت دوستان عرض می کنم:

نمیخوام وارد بحث توضیحات این تکنولوژی بشم، فقط توضیح کوتاهی واسه کسانی که با این تکنولوژی آشنایی ندارند میدم و آموزش رو شروع می کنیم:

EtherChannel تکنولوژی هست برای تجمیع چندین لینک Ethernet و تبدیل اونها به یک لینک مجازی واحد، با پهنای باند بیشتر، به عنوان مثال اگه 2 تا سوییچ یا 2 تا سرور رو که دارای 4 پورت Ethernet با سرعت 1 گیگابیت هستند رو به همدیگه متصل کنیم و مابینشون تکنولوژی EtherChannel یا Link Aggregation راه اندازی کنیم، لینک های 1 گیگابیتی از دید سیستم عامل و کاربر مخفی میشن و لینک نهایی رو به صورت 1 لینک 4 گیگابیتی مشاهده می کنند. دیگه زیاد وارد جزئیات نمیشم، اگه نیازی به توضیحات بیشتر بود میتونید تو کامنت ها مطرح کنید اونجا پاسخ میدم.

اولین نکته تو ساخت EtherChannel اینه که: تمامی لینک ها باید دقیقاً عین هم باشند، چه از نظر سرعت، دوپلکس، تنظیمات و...، برای اینکه از یکسان بودن تنظیمات لینک ها مطمئن بشیم بهترین روش استفاده از دستور default و ریست کردن تنظیمات به حالت پیش فرض IOS هست (همون تنظیمات کارخانه خودمون :دی)

من در این آموزش از مقلد EVE-NG و IOL لایه 2 استفاده کردم که فایل های سناریو رو هم ضمیمه می کنم برای دوستان علاقه مند...

آموزش راه اندازی EtherChannel به روش پیشنهادی سیسکو

در اینجا 2 سوییچ NMAXi__SW1 و NMAXi__SW2 با 3 تا لینک Ethernet با پهنای باند هر کدام 10 مگابیت بر ثانیه به همدیگه متصل شده اند، می خواهیم بین این 2 سوییچ یه لینک واحد به اسم port-channel 12 بسازیم که پهنای باندش در نهایت 30 مگابیت بر ثانیه بشه.

ابتدا با دستور default تنظیمات هر 3 لینک رو به حالت پیش فرض در میاریم (حتماً این کار رو بکنید، من خودم اوایل مقاومت نشون میدادم :دی بعد سناریوهایی واسم پیش اومد که نیم ساعت با پورت ها کلنجار می رفتم!)

NMAXi_SW1(config)#default interface range e0/0 - 2
NMAXi_SW2(config)#default interface range e0/0 - 2

حالا 3 اینترفیس رو با دستور interface range انتخاب می کنیم و اونارو تبدیل به لینک لایه 2 می کنیم (در بعضی سوئیچ های سطح بالا به صورت پیش فرض لایه 3 هستند واسه همین این قسمت رو اضافه کردم) بعدش اونارو عضو port-channel مربوطه می کنیم، دقت کنید که من port-channel رو به صورت دستی ایجاد نکردم، اجازه میدیم سوئیچ خودش این کارو بکنه:

NMAXi_SW1(config)#interface range e0/0 - 2
NMAXi_SW1(config-if-range)#switchport
NMAXi_SW1(config-if-range)#channel-group 12 mode active 
Creating a port-channel interface Port-channel 12

NMAXi_SW1(config-if-range)#
*Feb  3 11:08:28.747: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to down
*Feb  3 11:08:28.748: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to down
*Feb  3 11:08:28.748: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/2, changed state to down
NMAXi_SW1(config-if-range)#
*Feb  3 11:08:35.672: %EC-5-L3DONTBNDL2: Et0/0 suspended: LACP currently not enabled on the remote port.
*Feb  3 11:08:35.899: %EC-5-L3DONTBNDL2: Et0/2 suspended: LACP currently not enabled on the remote port.
*Feb  3 11:08:36.230: %EC-5-L3DONTBNDL2: Et0/1 suspended: LACP currently not enabled on the remote port.
NMAXi_SW2(config)#interface range e0/0 - 2
NMAXi_SW2(config-if-range)#switchport
NMAXi_SW2(config-if-range)#channel-group 12 mode active 
Creating a port-channel interface Port-channel 12

NMAXi_SW2(config-if-range)#
*Feb  3 11:09:28.747: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to down
*Feb  3 11:09:28.748: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to down
*Feb  3 11:09:28.748: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/2, changed state to down
NMAXi_SW2(config-if-range)#
*Feb  3 11:09:35.672: %EC-5-L3DONTBNDL2: Et0/0 suspended: LACP currently not enabled on the remote port.
*Feb  3 11:09:35.899: %EC-5-L3DONTBNDL2: Et0/2 suspended: LACP currently not enabled on the remote port.
*Feb  3 11:09:36.230: %EC-5-L3DONTBNDL2: Et0/1 suspended: LACP currently not enabled on the remote port.

همونطور که متوجه شدید سوئیچ خودش اینترفیس port-channel 12 رو ساخت (بهترین روش تو ساختن EtherChannel لایه 2 اینه که اجازه بدیم سوئیچ خودش اینترفیس مربوطه رو درست کنه این پیشنهاد خود سیسکو هست، ولی تو لایه 3 میگه اینترفیس port-channel رو خودتون بسازید و با دستور no switchport تبدیلش کنید به لایه 3 بعد اینترفیس لارو عضوش کنید.

بعد آقای Narbik Kocharians برای جلوگیری از خطاهای احتمالی از طرف سیستم عامل سوئیچ، پیشنهاد دادند پورت ها رو یک بار shutdown و بعد no shutdown کنید:

NMAXi_SW1(config-if)#int range e0/0 - 2
NMAXi_SW1(config-if-range)#sh
NMAXi_SW1(config-if-range)#
*Feb  3 11:25:24.857: %LINK-5-CHANGED: Interface Ethernet0/0, changed state to administratively down
*Feb  3 11:25:24.857: %LINK-5-CHANGED: Interface Ethernet0/1, changed state to administratively down
*Feb  3 11:25:24.858: %LINK-5-CHANGED: Interface Ethernet0/2, changed state to administratively down
*Feb  3 11:25:24.875: %LINK-3-UPDOWN: Interface Port-channel12, changed state to down
NMAXi_SW1(config-if-range)#no
*Feb  3 11:25:25.865: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to down
*Feb  3 11:25:25.872: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to down
*Feb  3 11:25:25.872: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/2, changed state to down
*Feb  3 11:25:25.885: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel12, changed state to down
NMAXi_SW1(config-if-range)#no sh
NMAXi_SW1(config-if-range)#
*Feb  3 11:25:30.835: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Feb  3 11:25:30.835: %LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
*Feb  3 11:25:30.835: %LINK-3-UPDOWN: Interface Ethernet0/2, changed state to up
*Feb  3 11:25:31.844: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
*Feb  3 11:25:31.844: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to up
*Feb  3 11:25:31.845: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/2, changed state to up
NMAXi_SW1(config-if-range)#
*Feb  3 11:25:32.799: %LINK-3-UPDOWN: Interface Port-channel12, changed state to up
*Feb  3 11:25:33.810: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel12, changed state to up

تو سوئیچ دوم هم همین کار رو انجام بدید

ببینید الان اینترفیس مربوطه ایجاد شده و به درستی کار می کنه:

NMAXi_SW1(config)#do sh etherchannel summa | begin Number of
Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
12     Po12(SU)        LACP      Et0/0(P)    Et0/1(P)    Et0/2(P)    

NMAXi_SW1(config)#do sh ip int br | exclude down            
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            unassigned      YES unset  up                    up      
Ethernet0/1            unassigned      YES unset  up                    up      
Ethernet0/2            unassigned      YES unset  up                    up      
Port-channel12         unassigned      YES unset  up                    up

الان پورت هایی که به port-channel مربوطه bundled شدند اختیارشون دست port-channel هست، کافیه شما port-channel رو عضو vlan 55 کنید، تمامی 3 پورتی که زیر مجموعه این port-channel هستند به صورت خودکار تنظیمات رو از port-channel میگیرند:

NMAXi_SW1(config)#int po 12
NMAXi_SW1(config-if)#swi access vlan 55
% Access VLAN does not exist. Creating vlan 55
NMAXi_SW1(config-if)#swi mode access
NMAXi_SW2(config)#int po 12
NMAXi_SW2(config-if)#swi access vlan 55
% Access VLAN does not exist. Creating vlan 55
NMAXi_SW2(config-if)#swi mode access
NMAXi_SW1(config-if)#do sh vlan br

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Et0/3
55   VLAN0055                         active    Po12
1002 fddi-default                     act/unsup 
1003 token-ring-default               act/unsup 
1004 fddinet-default                  act/unsup 
1005 trnet-default                    act/unsup 
NMAXi_SW1(config-if)#do sh run int e0/1
Building configuration...

Current configuration : 110 bytes
!
interface Ethernet0/1
 switchport access vlan 55
 switchport mode access
 channel-group 12 mode active
end

NMAXi_SW1(config-if)#do sh run int e0/2
Building configuration...

Current configuration : 110 bytes
!
interface Ethernet0/2
 switchport access vlan 55
 switchport mode access
 channel-group 12 mode active
end

الان ارتباط رو تست می کنیم:

NMAXi_SW2(config)#int vlan 55
*Feb  3 11:27:26.500: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan55, changed state to down
NMAXi_SW2(config-if)#ip add 10.55.0.2 255.255.255.0
NMAXi_SW2(config-if)#no sh
*Feb  3 11:27:36.207: %LINK-3-UPDOWN: Interface Vlan55, changed state to up
*Feb  3 11:27:37.214: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan55, changed state to up
NMAXi_SW1(config)#int vlan 55   
*Feb  3 11:26:58.715: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan55, changed state to down
NMAXi_SW1(config-if)#ip add 10.55.0.1 255.255.255.0
NMAXi_SW1(config-if)#no sh
*Feb  3 11:27:16.785: %LINK-3-UPDOWN: Interface Vlan55, changed state to up
*Feb  3 11:27:17.799: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan55, changed state to up
NMAXi_SW1(config-if)#do ping 10.55.0.2 repeat 20
Type escape sequence to abort.
Sending 20, 100-byte ICMP Echos to 10.55.0.2, timeout is 2 seconds:
.!!!!!!!!!!!!!!!!!!!
Success rate is 95 percent (19/20), round-trip min/avg/max = 1/1/1 ms

برای همتون آرزوی موفقیت دارم

نویسنده: نوید یحیی پور

منبع : جزیره سیسکو وب سایت توسینسو

هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی است

#آموزش_راه_اندازی_etherchannels_در_سیسکو #port-channel #آموزش_سیسکو #ccnp #آموزش_راه_اندازی_etherchannel #ccie
2 نظر
mohammad.saeb

درود بر شما عالی بود.

لطفا در مورد روش های load balancing و کاربردشون در شرایط مختلف هم اگه واستون ممکن بود یک مقاله بزارید.تشکر

نوید یحیی پور

بله حتما مینویسم

نظر شما
برای ارسال نظر باید وارد شوید.
از سرتاسر توسینسو
تنظیمات حریم خصوصی
تائید صرفنظر
×

تو می تونی بهترین نتیجه رو تضمینی با بهترین های ایران بدست بیاری ، پس مقایسه کن و بعد خرید کن : فقط توی جشنواره پاییزه می تونی امروز ارزونتر از فردا خرید کنی ....