در توسینسو تدریس کنید

و

با دانش خود درآمد کسب کنید

آموزش ساخت Bridge در روتر سیسکو

سلام به تمامی دوستان توسینسویی عزیز ، امروز میخوام یه نکته جالبی رو خدمتتون عرض کنم. تا حالا شده بخواهید کاری کنید که پورت های روتر عین یه سوئیچ تو یک Broadcast Domain قرار بگیرند؟ قبل از شروع آموزش اشاره کنم که این مطلب در دسته بندی Advanced Technologies قرار می گیره و برای درک موضوع باید حداقل دوره CCNP R&S رو گذرونده باشید (نگذرونده باشیدم نگران نباشید با چندین بار تمرین این سناریو کاملا متوجه موضوع میشید) فرض کنید طبق شکل زیر ۳ تا روتر دارید که توسط پورت Serial به همدیگه متصل شده اند و ازتون خواسته شده بین R5 و R7 همسایگی OSPF راه اندازی کنید یعنی بدون کانفیگ IP Address روی پورت های روتر R6 و بدون استفاده از هرگونه Tunnel مثل GRE کاری کنید که دو روتر R5 و R7 همسایه یا Adjacent همدیگه بشن و روت های بینشون به صورت کامل (Full) تبادل بشه.

وب سایت توسینسو

روترهای سیسکو با استفاده از قابلیت Bridge میتونن پورت های سریالشون و حتی چندین پورت Ethernet رو به همدیگه Bridge کنند (تو میکروتیک هم این قابلیت وجود داره که اسمش Bridge هست) و در این بین از پروتکل Spanning-Tree برای جلوگیری از Loop استفاده کنند. برای این کار ابتدا باید IRB یا Integrated Routing and Bridging رو رو روتر فعال کنیم:

R6(config)#bridge irb

الان کافیه پورت های مربوطه رو عضو Bridge Group کنیم (توجه کنید که قرار نیست به اینترفیس های سریال روتر R6 آی پی آدرسی اختصاص بدیم):

R6(config)#interface s2/0
R6(config-if)#bridge-group 57
R6(config-if)#no shutdown
R6(config-if)#interface s3/0
R6(config-if)#bridge-group 57
R6(config-if)#no sh

بعد باید روی این Bridge Group پروتکل Spanning Tree رو برای جلوگیری از ایجاد Loop در شبکه فعال کنیم (منظور از ieee همون Spanning-Tree ساده یا 802.1D هست):

R6(config)#bridge 57 protocol ieee

الان روتر R6 ما تبدیل به یه سوئیچ ۲ پورت شده که یکی از پورت هاش S2//0 هست و دومی S3//0 و قراره واسمون پورت Ethernet رو شبیه سازی کنه.

حتی می تونیم برای این روتر یه اینترفیس مجازی که متصل به Bridge هست بسازیم و براش mac-address و IP Address اختصاص بدیم (معادل SVI تو سوئیچ های Catalyst سیسکو):

R6(config)#interface bvi 57
R6(config-if)#mac-address 0000.6666.6666
R6(config-if)#ip address 10.57.0.6 255.255.255.0
R6(config-if)#no sh

برای اینکه روتر بتوننه پروتکل IP رو رو این Bridge Virtual Interface روت کنه باید روتینگ IP رو روی این bridge-group فعال کنیم:

R6(config)#bridge 57 route ip

کار ما با روتر R6 تموم شد. الان کافیه همون کارایی که روی R6 انجام دادیم رو روی R5 و R7 انجام بدیم (فقط واسه یک اینترفیس):

R5(config)#bridge irb
R5(config)#bridge 57 protocol ieee
R5(config)#bridge 57 route ip
R5(config)#int s2/0
R5(config-if)#bridge-group 57
R5(config-if)#no sh
R5(config-if)#int bvi 57
R5(config-if)#mac-address 0000.5555.5555
R5(config-if)#ip add 10.57.0.5 255.255.255.0
R5(config-if)#no shutdown
R7(config)#bridge irb
R7(config)#bridge 57 protocol ieee
R7(config)#bridge 57 route ip
R7(config)#int s3/0
R7(config-if)#no sh
R7(config-if)#bridge-group 57
R7(config-if)#int bvi 57
R7(config-if)#mac-address 0000.7777.7777
R7(config-if)#ip address 10.57.0.7 255.255.255.0
R7(config-if)#no sh

الان میتونیم ارتباط R5 و R7 رو با همدیگه تست کنیم:

R5(config-if)#do ping 10.57.0.7 repeat 30
Type escape sequence to abort.
Sending 30, 100-byte ICMP Echos to 10.57.0.7, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (30/30), round-trip min/avg/max = 23/27/33 ms

همه چی واسه OSPF Neighborship دو روتر R5 و R7 آماده هست:

R5(config-if)#router ospf 1
R5(config-router)#router-id 0.0.0.5
R5(config-router)#network 10.57.0.5 0.0.0.0 area 0
R7(config-if)#router ospf 1
R7(config-router)#router-id 0.0.0.7
R7(config-router)#network 10.57.0.7 0.0.0.0 area 0

دو روتر با همدیگه همسایه OSPF ای میشن:

R5(config-router)#do sh ip ospf ne

Neighbor ID     Pri   State           Dead Time   Address         Interface
0.0.0.7           1   FULL/DR         00:00:34    10.57.0.7       BVI57

الان یه اینترفیس loopback روی R7 ایجاد می کنیم و اونو با OSPF به R5 تبلیغ می کنیم تا ببینیم روت ها درست منتقل میشن یا نه:

R7(config-router)#int loopback 1
*Feb  4 02:02:13.745: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up 

R7(config-if)#ip add 172.16.7.7 255.255.255.0
R7(config-if)#ip ospf ne point-to-point
R7(config-if)#router ospf 1
R7(config-router)#network 172.16.7.7 0.0.0.0 area 0

و اینم نتیجه:

R5(config-router)#do sh ip route ospf | begin Gate
Gateway of last resort is not set

      172.16.0.0/24 is subnetted, 1 subnets
O        172.16.7.0 [110/65] via 10.57.0.7, 00:00:38, BVI57

نویسنده: نوید یحیی پور

منبع : جزیره سیسکو وب سایت توسینسو

هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی است

#ساخت_بریج_در_روتر_سیسکو #تبدیل_روتر_به_سوییچ #bvi #روتر_سیسکو

1 نظر
ebit

ضمن تشکر

تفاوت bridge group با bridge-domain در چیست و یک مثال کاربری بهمراه نمونه کانفیگ از bridge-domain لطفا ذکر نمائید.

نظر شما
برای ارسال نظر باید وارد شوید.
از سرتاسر توسینسو
تنظیمات حریم خصوصی
تائید صرفنظر
×

تو می تونی بهترین نتیجه رو تضمینی با بهترین های ایران بدست بیاری ، پس مقایسه کن و بعد خرید کن : فقط توی جشنواره تابستانه می تونی امروز ارزونتر از فردا خرید کنی ....