در توسینسو تدریس کنید

و

با دانش خود درآمد کسب کنید

آموزش راه اندازی Static Route در روترهای سیسکو بصورت سناریو بخش 1

در مطالب قبلی در وب سایت در خصوص اینکه Static Route چیست و تفاوت آن با Default Route و Dynamic Routing چیست صحبت کردیم ، اما فراموش نکنیم که انجمن تخصصی فناوری اطلاعات ایران هیچوقت به مطرح کردن مفاهیم بسنده نمی کند و در این مطلب آموزشی قصد داریم به شما یاد بدهیم که چگونه Static Route را روی روترهای سیسکو اضافه کنیم ، فقط از شما خواهش می کنیم بعد از کپی کردن مطلب حتما نام انجمن تخصصی فناوری اطلاعات ایران و اگر دوست داشتید نویسنده را در وب سایت خود قرار دهید ، به هر حال Static Route ها در دستورات IOS روتر سیسکو به دو شکل زیر تعریف می شوند :
Router(config)#ip route destination_network subnet_mask default_gateway [administrative_distance] [permanent]
یا
Router(config)# ip route destination_network subnet_mask interface_to_exit [administrative_distance] [permanent]

شاید برخی موارد در دستورات بالا مبهم به نظر برسد بنابراین همه قسمت ها را توضیح می دهم ، دستور اصلی که ip route است و مشخص است که قرار است برای ایجاد static route ابتدا این دستور را باید وارد کنیم ، در قسمت destination__network شما باید آدرس شبکه مقصدی که قرار است به سمت آن route داشته باشید را قرار بدهید از ترجمه کلمه کاملا مشخص است .

در قسمت subnet__mask باید subnetmask مربوط به شبکه مقصد را وارد کنید ، در قسمت default gateway قطعا آدرس default gateway برای خروج ترافیک از شبکه را مشخص می کنید ، در در قسمت interface__to__exit شما می توانید ترافیک را به جای Gateway از یک Interface مشخص عبور دهید و در خصوص Administrative Distance هم که قبلا نکته ای در انجمن تخصصی فناوری اطلاعات ایران در همین لینک قرار داده ایم می توانید عدد مورد نظر را در این قسمت وارد کنید.

کلمه permanent یا persistent باعث می شود route ای که شما اضافه می کنید در routing table روتر حتی بعد از خاموش و روشن شدن یا دچار مشکل شدن روتر باقی بماند و دقیقا مشابه کاری را انجام می دهد که سویچ –p در دستور route add ویندوز انجام می دهد.


ایجاد لابراتوار تمرینی برای Static Route

در تصویر پایین که بصورت اختصاصی برای سناریوهای انجمن تخصصی فناوری اطلاعات ایران طراحی شده است شما دیاگرام سناریوی لابراتوار Static Route را مشاهده می کنید. ما در این سناریو سه عدد روتر به همراه سه عدد سویچ و سه عدد سیستم Host داریم که به هم به شکل زیر متصل شده اند. اسامی روترها و Host ها و آدرس های IP هر کدام از آنها در تصویر به خوبی نمایش داده شده است ، Interface های روترها و سویچ هایی که به هم متصل شده اند نیز به خوبی نمایش داده شده است. سناریوی ما بر اساس همین شکل در نرم افزار Packet Tracer یا هر لابراتوار واقعی و مجازی دیگری قابل پیاده سازی است.

سناریوی Static Routing


اگر با ارتباطات کنسول روتر آشنایی ندارید می توانید با استفاده از این آموزش که چگونه به پورت سریال روتر خود با استفاده از پورت کنسول متصل شویم ؟ مراجعه کنید. یا اگر پورت کنسول را دارید می توانید از طریق آموزش چگونه با استفاده از PUTTY به Terminal روتر خود دسترسی پیدا کنیم ؟ مراجعه کنید. البته توجه کنید که شما در نرم افزارهای مجازی ساز اینقدر دچار مشکل نخواهید شد اما با توجه به اینکه همه این آموزش ها قبلا در انجمن تخصصی فناوری اطلاعات ایران قرار گرفته است بهتر است اصولی برخورد کنیم.

قرار دادن Hostname و IP Address برای ITPRO-R1

با استفاده از پورت کنسول به روتر اول متصل شوید و از طریق دستورات IOS اسم آن را به ITPRO-R1 به شکل زیر تغییر دهید :
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname ITPRO-R1
ITPRO-R1(config)#
با استفاده از دستور زیر وارد configuration mode مربوط به fast ethernet interface fa0//0 شوید و بر روی ITPRO-R1 آدرس IP را به شکل 172.16.0.1//16 تنظیم کنید :
ITPRO-R1>enable
ITPRO-R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R1(config)#interface fa0/0
ITPRO-R1(config-if)#ip address 172.16.0.1 255.255.0.0
ITPRO-R1(config-if)#no shutdown
با استفاده از دستور زیر وارد configuration mode مربوط به serial interface s0//0 روتر ITPRO-R1 شوید و آدرس IP این Interface را 172.17.0.1//16 قرار دهید. همچنین با استفاده از دستور clock rate عدد مربوطه را برای s0//0 به شکل 64000 قرار دهید تا در نقش یک DCE عمل کند. برای اطلاعات بیشتر در این خصوص می توانید به تفاوت DCE و DTE در همین انجمن مراجعه کنید.
ITPRO-R1>enable
ITPRO-R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R1(config)#interface s0/0
ITPRO-R1(config-if)#clock rate 64000
ITPRO-R1(config-if)#ip address 172.17.0.1 255.255.0.0
ITPRO-R1(config-if)#no shutdown
با استفاده از دستور copy running-config startup-config در enable mode تنظیمات را ذخیره کنید . اگر می خواهید در این خصوص اطلاعات بیشتری به دست بیاورید به این نکته در خصوص تفاوت running config و startup config در چیست در انجمن تخصصی فناوری اطلاعات ایران مراجعه کنید.

قراردادن Hostname و IP Address برای ITPRO-R2

به پورت کنسول روتر دوم متصل شوید و با استفاده از دستورات IOS به شکل زیر Hostname روتر را به ITPRO-R2 تغییر دهید :
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname ITPRO-R2
ITPRO-R2(config)#
با استفاده از دستور زیر وارد configuration mode مربوط به fast ethernet interface fa0//0 شوید و بر روی ITPRO-R1 آدرس IP را به شکل 172.18.0.1//16 تنظیم کنید :
ITPRO-R2>enable
ITPRO-R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R2(config)#interface fa0/0
ITPRO-R2(config-if)#ip address 172.18.0.1 255.255.0.0
ITPRO-R2(config-if)#no shutdown
با استفاده از دستور زیر در configuration mode مربوط به serial interface s0//0 این روتر آدرس IP روتر ITPRO-R2 را به شکل 172.17.0.2//16 قرار بدهید.
ITPRO-R2>enable
ITPRO-R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R2(config)#interface s0/0
ITPRO-R2(config-if)#ip address 172.17.0.2 255.255.0.0
ITPRO-R2(config-if)#no shutdown
با استفاده از دستورات زیر در configuration mode مربوط به serial interface s0//1 بر روی روتر ITPRO-R2 آدرس IP این interface را به 172.19.0.1//16 تغییر دهید. همچنین با استفاده از دستور clock rate عدد مربوطه را برای s0//1 به شکل 64000 قرار دهید تا در نقش یک DCE عمل کند. برای اطلاعات بیشتر در این خصوص می توانید به تفاوت DCE و DTE در همین انجمن مراجعه کنید.
ITPRO-R2>enable
ITPRO-R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R2(config)#interface s0/1
ITPRO-R2(config-if)#clock rate 64000
ITPRO-R2(config-if)#ip address 172.19.0.1 255.255.0.0
ITPRO-R2(config-if)#no shutdown
با استفاده از دستور copy running-config startup-config در enable mode تنظیمات را ذخیره کنید .

قرار دادن Hostname و IP Address برای ITPRO-R3

از طریق کابل کنسول به روتر ITPRO-R3 متصل شوید و با استفاده از دستورات IOS زیر Hostname را به ITPRO-R3 تغییر دهید :
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname ITPRO-R3
ITPRO-R3(config)#
با استفاده از دستورات IOS زیر در محیط configuration mode مربوط به fast ethernet interface fa0//0 روتر ITPRO-R3 تنظیمات آدرس IP آن را به 172.20.0.1//16 تغییر دهید .
ITPRO-R3>enable
ITPRO-R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R3(config)#interface fa0/0
ITPRO-R3(config-if)#ip address 172.20.0.1 255.255.0.0
ITPRO-R3(config-if)#no shutdown
با استفاده از دستور IOS زیر configuration mode مربوط به serial interface s0//1 را روی روتر ITPRO-R3 باز کنید و تنظیمات آدرس IP آن را به شکل زیر بصورت 172.19.0.2//16 قرار دهید.
ITPRO-R3>enable
ITPRO-R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
ITPRO-R3(config)#interface s0/1
ITPRO-R3(config-if)#ip address 172.19.0.2 255.255.0.0
ITPRO-R3(config-if)#no shutdown
با استفاده از دستور copy running-config startup-config در enable mode تنظیمات را ذخیره کنید. ITPRO باشید

نویسنده : محمد نصیری
منبع : جزیره سیسکو وب سایت توسینسو
هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی می باشد
#نوشتن_static_route_در_سیسکو #راه_اندازی_static_route_در_سیسکو #static_route_در_سیسکو #static_route_چیست #تفاوت_static_routing_و_dynamic_routing #سناریوی_static_route #چگونه_static_route_ایجاد_کنیم #تفاوت_static_route_و_dynamic_route
عنوان
1 آموزش راه اندازی Static Route در روترهای سیسکو بصورت سناریو بخش 1 رایگان
2 آموزش راه اندازی Static Route در روترهای سیسکو بصورت سناریو بخش 2 رایگان
زمان و قیمت کل 0″ 0
13 نظر
network1991

باتشکر از مقاله خوبتون...من هرچی میخام مثل شکل بالا شبکه 172.18.0.0 رو درست کنم اررور میده...مگه نباید ماژول اضافه کنیم...خب من این کارو کرددم ولی نمیشه

وب سایت توسینسو

محمد نصیری

لطفا سئوالتون رو در تالار مطرح کنید با تشکر

network1991

دوست عزیزخب سوال مربوط به شکل بالاست

محمد نصیری

نوع کابلتون باید crossover باشه چون دستگاه ها غیر مشابه هستند از طرفی به سریال بودن پورت های روتر ها در سناریو دقت کنید شما fa دارید نه s در تصویری که من میبینم

network1991

کابل کراس که انتخاب میکنم سه گزینه میاد serial,console,auxiliary من جون ماژول انتخاب کردم نمیدونم کدومش رو انتخاب کنم

وب سایت توسینسو

محمد نصیری

Serial رو انتخاب کنید ...

network1991

باتشکر ازشما..سریال رو انتخاب کردم ولی ارتباطش قطع و هر کاری میکنم روشن نمیشه

وب سایت توسینسو

محمد نصیری

دوست عزیز دقت کنید همه روترها با استفاده از پورت سریال به هم وصل شدند ، در سناریویی که من از شما میبینم fa دارم میبینم یعنی شما به جای سریال که با s در تصویر مقاله عنوان شده از fast Ethernet روتر دارید اونها رو متصل می کنید که مشکل میخورید،از fa ها برای اتصال سویچ ها به روترها با استفاده از کابل کراس استفاده کنید. لطفا یکبار دیگه به تصویر سناریو دقت کنید و به حروف ریزی که در کنار پورت های روتر و سویچ نوشته شده بیشتر دقت کنید.

darya9431

سلام من نمی تونم مسیریابی رو انجام بدم اگه ممکنه در

وب سایت توسینسو
مسیریابی روتر 6 راهنماییم کنید

محمد نصیری

لطفا از گزینه سوال بپرسید استفاده کنید سپاسگزارم

کامبیز ذوقی

سلام وخسته نباشید

ماژول WIC-1T کلا برای چیه؟ وچه فرقی با نوعWIC-2Tداره؟

ab2lee

سلام استاد خسته نباشی

در چه شرایطی باید از کابل سریال استفاده کرد؟؟؟منظورم با توجه به سرعت کمش اضلا کابرد داره؟؟

محمد نصیری

سلام و عرض ادب ، کابل سریال در تنظیمات اولیه فقط کاربرد داره ! بعد از اومدن تو شبکه به ندرت استفاده میشه

نظر شما
برای ارسال نظر باید وارد شوید.
از سرتاسر توسینسو
تنظیمات حریم خصوصی
تائید صرفنظر
×

تو می تونی بهترین نتیجه رو تضمینی با بهترین های ایران بدست بیاری ، پس مقایسه کن و بعد خرید کن : فقط توی جشنواره پاییزه می تونی امروز ارزونتر از فردا خرید کنی ....