درخواست های ارتباط
جستجو تنظیمات
لیست دوستان من

معرفی پروتکل مسیریابی RIP یا Routing Information Protocol و راه اندازی یک سناریوی کاملا عملی

7 نظرات
با سلام خدمت همه مهندسین شبـــکه ، در این آمــــوزش قصد داریم با پروتکل روتینگ RIP آشنا بشیم و یه سناریو رو همراه هم اجرا کنیم. این Routing Protocol از نوع Distance Vector می باشد و به طور کلی از الگوریتم مسیر یابی Bellmanford استفاده می کند. این الگریتم بسیار سبک است و به همین دلیل Load بسیار کمی روی CPU و RAM روتر می اندازد.

مشخصات پروتکل مسیریابی RIP


  • Administrative Distance (AD) = 120
  • Metric = Hop Count
  • در Routing Table با حرف R نشان داده می شود.
  • Infinite Metric = 16
  • دو Version نیز دارد که به RIP V1 و RIPv2 معروف است.

در این Routing protocol بین روتر ها بسته های update ارسال می شود که شامل اطلاعات مربوط به شبکه هایی است که آن روتر در اختیار دارد.در RIP V1 بسته های update با خود Subnet mask حمل نمی کنند در نتیجه نسخه اول RIP از subnetting ، supernetting و VLSM پشتیبانی نمی کند و بسته های update به آدرس 255.255.255.255 ارسال می شود.در RIPv2 بسته های update با خود Subnet mask حمل می کنند پس بر خلاف نسخه اول ، این نسخه از subnetting ، supernetting و VLSM پشتیبانی می کند و بسته های update به آدرس 224.0.0.9 که یک آدرس از نوع multicast است ، ارسال می شود. Update های RIP هر ۳۰ ثانیه یک باربه صورت Full ارسال می شود.

  • RIP V1 اهراز هویت (Authentication) ندارد.
  • RIPv2 اهراز هویت ( Authentication ) دارد.

به طور کلی RIP ، Convergence Time بالایی دارد و دید به Topology Table شبکه ندارند در نتیجه مستعد Loop است به همین دلیل این Routing protocol روش هایی برای جلوگیری از Loop در اختیار دارد.

روش های جلوگیری از Loop


  1. Split Horizon بدین معنا است که روتر حق ندارد مسیری را که از یک روتر دیگر گرفته است دوباره به آن روتر اعلام کند.
  2. Route Poisoning بدین معنا ست که اگر مسیری قطع شده آن مسیر با Infinite Metric=16 نشان داده شود .
  3. Triggered Update بدین معنا است که روتر نباید صبر کند تا زمان Full update ( که هر ۳۰ ثانیه یک بار است) برسد.بلکه هر موقع نیاز به Route Poisoning شد بسته update را در همان لحظه ارسال کند .
  4. Hold down Timer بدین معنا است که هر زمان بسته Update به روتری رسید ۱۸۰ ثانیه صبر کند و سپس تغییرات را در Routing Table خود اعمال کند.
  5. Split Horizon With Poison Reverse بدین معنا است که روتر حق ندارد مسیری را که از یک روتر دیگر گرفته است دوباره به آن روتر اعلام کند مگر اینکه آن مسیر Route Poison شده باشد.

و بدین صورت و با استفاده از این پنج روش RIP قادر است در صورت به وجود آمدن Loopتا حدی از بروز فاجعه جلوگیری کند.

برای یادگیری دستورات RIP به بررسی یک سناریو می پردازیم


Image


در این سناریو ۳ روتر وجود دارد که روتر ۱ و روتر ۳ هر کدام به یک سوئیچ و همچنین فرض کنید که سوئیچ ها نیز هر کدام به تعدادی کامپیوتر وصل هستند. ما می خواهیم با استفاده از روش RIP ارتباط تمامی روتر ها و سوئیچ ها را با یکدیگر برقرار کنیم.در ابتدا باید وارد هر یک از روتر ها شده و اینترفیس های مربوطه را روشن کرده سپس به آن ها IP های مورد نظر را بدهیم و بعد از این config کردن RIP را آغاز می کنیم.

اختصاص IP Address برای اینترفیس های Fast Ethernet و Serial روتر


با استفاده از دستورات زیر در قسمت CLI روترها بر اساس سناریو آموزش IP های اینترفیس های روتر رو اختصاص میدیم:
Router-1:
Router(config)#interface fastehernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/0
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#clack rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Router-2:
Router(config)#interface serial0/0
Router(config-if)#ip address 10.10.10.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/1
Router(config-if)#ip address 11.11.11.1 255.255.255.0
Router(config-if)#clack rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Router-3:
Router(config)#interface fastehernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/0
Router(config-if)#ip address 11.11.11.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit
بعد از اختصاص IP ها بر روی اینترفیس روترها حال نوبت به کانفیگ ارتباط این 2 شبکه و روترها باهم با استفاده از پروتکل RIP هست که برای انجام این کار نیز دستورات زیر را بر روی روترها انجام میدیم:
Router-1
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 172.16.88.0
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

Router-2
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 11.11.11.0
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

Router-3
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 192.168.1.0
Router(config-router)#network 11.11.11.0
Router(config-router)#exit

در صورت نیاز به فایل Packet Tracer کانفیگ شده این سناریو میتونید از لینک زیر دانلود کنید:
دانلود فایل Config شده سناریو در Packet Tracer

با آرزوی مـــوفقیت

نویسنده : بـــهزاد حسن زاده
منبع : انجمن تخصصی فناوری اطلاعات ایران
هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی می باشد
آیا این مطلب را پسندیدید؟
  • باتشکرازدوست عزیز...چجوری میتونیم قابلیت های Route Poisoningو..رو ببینیم که فعال هستند یا نه؟
  • با سلام خدمت شما وتشکر از اموزشتان یک سوال در خصوص این سناریو داشتم
    1- در قسمت پیاده سازی پروتوکل جلوی عبارت network باید net id هریک از شبکه های متصل به روتر رانوشت که مثلا درمورد روتر شماره یک میشه net id اینترفیس سریال 0/0 از روتر شماره 2
    که درواقع ای پی ان 10.10.10.2بوده پس net id ان 10.10.10.0 میشه
    این چیزی که گفتم درست هست یا نه ؟
    2- مثلا در مورد همین روتر یک ای پی 172.16.88.0 چیه ؟
    3- اگر بخواهیم ورژن 2 از این پروتوکل را پیاده سازی کنیم چه تغییراتی در این پیادهسازی باید بدهیم ؟
    خیلی ممنون میشم اگر جوابم را بدین چون خیلی لازمش دارم .
  • 1) بله دوست عزیز گفته شما درسته برای معرفی شبکه های که وصل هستن کافیه نتورک ID رو بنویسیم
    2 ) این آی پی که گفته IP شبکه داخلی هست که به سوئیچ وصل می باشد
    3 ) بعد از زدن این دستورات شما بازده دستور version 2 میگی که از ورن 2 استفاده کنه و حتی میتونی برای ارسال و دریافت هم ورژن مشخص کنی برای مثال بگی با ورژن 2 بفرسته و بتونه با ورژنهای 1 و 2 دریافت کنه
  • با سلام وتشکر بابت جواب شما
    در خصوص مورد سوم چطوری میتونم برای ارسال ودر یافت ورژن های مختلف ایجاد کنم اگه لطف کنید وکدش رو بنویسد ممنون میشم یه سوال دیگه اگه مثلا سوییچی که به روتر شماره یک متصل هست vlan بندی شده باشه اون وقت چطوری این شبکه داخلی برای مسیریابی به روتر معرفی بشه چون من اصلا فکر میکردم لازم نیست در هیچ شرایطی ip شبکه داخلی رو به روتر معرفی کنم.
    ممنون میشم راهنمایی بفرمایید.
  • Router1:
    Router(config-router)#version 1
    Router(config-router)#version 2
    
    شما با یکی از این دو دستور بالا مشخص میکنی که از کدامیک ورژن ها استفاده کنه برای routing
    بعد برای مشخص کردن send و receive باید داخل مد اینترفیس شده و از دستورات زیر استفاده بکنی
    router(config-if)#ip rip send version 1
    or 
    router(config-if)#ip rip send version 2
    
    router(config-if)#ip rip receive version 1
    or
    router(config-if)#ip rip receive version 2
    
    router(config-if)#ip rip send version 1 2
    
    router(config-if)#ip rip receive version 1 2
    
    امیدوارم دستورات برات قابل درک باشه دوست عزیز
  • در جواب سوال vlan بندی شده یک سوئیچ مثلا چندین vlan داشته باشی که بخوای به یک روتر شبکه داخلیش رو معرفی کنی باید از Inter Vlan Routing استفاده کنی
  • یه سوال:
    اگر طبق شکل جلو بریم
    شما network id پشت روتر یک رو تو شکل 172.16.88.0 قرار دادین
    اونوقت چطوری آی پی f0/0 روتر یک رو 192.168.1.1 تنظیم کردین؟؟؟


برای ارسال نظر ابتدا به سایت وارد شوید

arrow