درخواست های ارتباط
جستجو
لیست دوستان من
صندوق پیام
همه را دیدم
  • در حال دریافت لیست پیام ها
صندوق پیام
رویدادها
همه را دیدم
  • در حال دریافت لیست رویدادها
همه رویدادهای من
تخفیف های وب سایت
همه تخفیف ها

عضویت در

کانال تلگرام

توسینسو

اطلاعات مطلب
مدرس/نویسنده
صادق شعبانی
امتیاز: 72450
رتبه:12
77
91
19
410
صادق شعبانی / ccna/ccnp/mcitp/ceh ---------------------------------- انسانی که کنار میکشه هیچوقت پیروز نمیشه و انسانی که پیروز میشه هیچوقت کنار نمی کشه. پروفایل کاربر

سیسکو آسان است! ( قسمت دوم )

تاریخ 47 ماه قبل
نظرات 14
بازدیدها 1874

بسم الله الرحمن الرحیم

*در ابتدا این توضیح رو بدم که این تایپیک در ادامه تایپیک قبلی هست و کانفیگ های مربوط و ترانک رو در قسمت قبل انجام دادم و در این تایپیک ادامه کانفیگ ها که در خصوص
inter vlan routing هست ، ادامه میدیم.*


inter vlan routing یعنی اینکه vlan های متفاوت با هم ارتباط داشته باشند. برای ارتباط pc ها با آی پی های مختلف ( ارتباط شبکه های مختلف ) نیازمند دستگاهی به نام روتر هستیم که با تعریف default gateway ، روتر را به pc معرفی می کنیم. تصویر پایین رو ببینید :

1



2 تا pc ما ، که در 2 تا شبکه ی متفاوت هستند ، به واسطه روتر ، باهمدیگه در ارتباط هستند.خب ، مشکلی نیست تا اینجا ولی حالا بذارید من تو شکل بالا یه تغییراتی ایجاد کنم :

2



حالا نظرتون چیه؟ آیا هنوز هم 2 شبکه با هم در ارتباط هستند؟من که میگم نه ! بیاید از سطح خیلی پایین به شکل نگاه کنیم ، 2 تا کامپیوتر در 2 شبکه ی متفاوت داریم که به یک سوییچ وصل هستند و این سوییچ هم توسط یک کابل ، که ترانک هست به روتر وصل شده. حالا بذارید یه چیزهایی رو از قسمت قبلی یادتون بیارم ، گفته بودم برای ارتباط بین 2 تا سوییچ ، 2 راه وجود داره ، یکیش استفاده از ترانک بود و روش دیگه اینکه من به ازای هر vlan یک کابل شبکه بذارم که گفتم زیاد جالب نیست . اما بزارید یه مفهومی بین ما خوب جا بیفته :

3


اگر من به ازای هر vlan ، یه مسیر ( کابل بذارم ) اون ترافیک یک مسیر کاملا" اختصاصی داره .اما اگه من یه لینک ترانک بزارم :

4


چون من فقط یک مسیر دارم ، پس من به دیتاهایی که دارم میفرستم تگ میزنم .بزارید یه مثال بزنم ، ما بچه های it pro قصد داریم یه مسابقه فوتبال راه بندازیم و تو زمین مسابقه ، من و هم تیمی هام ، یه رنگ لیاس ( = یک مدل تگ ) می پوشیم ، تیم مقابل هم قطعا" رنگ لباسش متفاوت از تیم ما (=تگ متفاوت)خواهد بود. پس تو زمین مسابقه ، ما 2 تیم با 2 رنگ لباس متفاوت می بینیم و تو لینک ترانک هم ما 2 مدل تگ می بینیم که اون دیتاها فقط تو اون مسیر تگ مخصوص به خودشون رو دارن ، درست مثل هر کردوم از ما که بیرون از اون مسابقه لباس خودمون رو میپوشیم ولی تو مسابقه فوتبال یک مدل لباس رو که وقتی مسابقه تموم میشه ، ما اون لباس رو عوض میکنیم و لباس خودمون رو می پوشیم ، تو ترانک هم همینطوره ، اون دیتا وقتی خواست وارد ترانک بشه تگ می خوره ، وقتی هم خواست از سوییچ خارج بشه ، در سمت مقابل سوییچ تگش رو بر می داره. برگردیم به این شکل :

5


حالا که مطلب خوب جا افتاد ، بیاید به این شکل خوب نگاه کنیم ، دیتای ما موقع ورود به سوییچ تگ می خوره ، اما در سمت مقابل سوییچی نیست که تگ ها رو برداره ، حالاچیکار باید کرد؟ شاید حالا باید ما به روتر مفهوم تگ رو بفهمونیم! خب ، حالا یه کوچولو تخصیی با هم صحبت کنیم ، برای اینکه روتر vlan رو بفهمدو تگ dot1q ای که سوییچ به دیتا زده رو متوجه شود و بتواند از آن استفاده کند باید از مفهومی به اسم subinterface استفاده کنیم.

Router(config)# interface fa0/0 .<id>
Router(config-if)#encapsulation dot1q  <vlan id >
Router(config-if)#ip address <ip >  <subnet mask>

خب ،تو خط اول ما یه تگی رو به این اینترفیس میزنیم، هر شماره ای که دوست داشتید ، اون شماره نقشی در عملکرد روتر نداره. تو خط دوم، میگم این دیتا برای اون شماره vlan هست که بصورت dot1q ، انکپسولیت (encapsulate) شده. تو خط سوم ، اون ای پی ای که در روتر ، به vlan اختصاص داده ایم را بعنوان dafault gateway معرفی میکنیم. خب این یعنی چی؟ بزارید یه یادآوری برای درک بهتر این مفهوم داشته باشیم :

6


ما یه روتر داریم که 2 تا پا توی 2 شبکه داره ، هر کدوم از این پاهاش ، یک ip داره ، برای شبکه سمت چپ ، ip1 و برای شبکه سمت راست ip 2 . حالا من در default gateway کامپیوترها بسته به شبکه ای که داخلش هستند ، اون ip رو وارد میکنیم.خب ، بریم سر سناریومون ببینیم که داستانش چطور میشه :

7


ما در درس قبل کانفیگ های مربوط به vlan و ترانک رو انجام دادیم و حالا قصد داریم بعداز بحث های تئوری بالا ، بصورت عملی ، inter vlan routing رو پیاده سازی کنیم. ابتدا پورت رو فعال میکنیم :

Router ( config ) #int fa 0/0
Router ( config ) #no shut

و طبق کانفیگ هایی که گفتم ، پیش میریم :

Router ( config ) # int fa0/0.10
Router ( config-subif ) #encapsulation dot1q 10

در اینجا به روتر می فهمونم که این دیتای انکپسولیت شده برای vlan 10 هست.

Router ( config-subif ) #ip add 192.168.10.1  255.255.255.0

همچنین آی پی 192.168.10.1 رو به vlan 10 اختصاص داده و پس از آن ، این ip رو بعنوان dfault gate way در pc در نظر میگیرم.

8


یادآوری مجدد


6.1


همونطور که در توضیحات بالا گفتم ، روتر ما 2 تا پا در 2 شبکه متفاوت داره ، آی پی پای سمت چپ هر چی که بود ، همون رو برای default gateway تنظیم میکنیم ، این کامند هم منظورش همینه . به زبان ساده تر سناریوی ما این مدلیه :

1t


که در واقع میشه گفت در اصل و اگه ما به ازای هر vlan ، یک کابل بگذاریم اینطوری میشه :

4t


و از اونجا که هر پای روتر در یک شبکه هست ، ما آی پی اون پا رو بعنوان default gateway روی pc ، تنظیم می کنیم.

Router ( config-subif ) #ip add 192.168.10.1  255.255.255.0

بقیه کانفیگ ها برای مابقی vlan ها ، مشابه کانفیگ بالاست.


==================================

Router ( config ) # int fa0/0.20
Router ( config-subif ) #encapsulation dot1q 20
Router ( config-subif ) #ip add 192.168.20.1  255.255.255.0
و همچنین تنظیم آی پی 192.168.20.1   در pc  مربوطه برای default gateway

***
Router ( config ) # int fa0/0.30
Router ( config-subif ) #encapsulation dot1q 30
Router ( config-subif ) #ip add 192.168.30.1  255.255.255.0
Router ( config ) # int fa0/0.40
Router ( config-subif ) #encapsulation dot1q 40

من میخواهم که برای vlan 40 یه توضیح بنویسم :

Router ( config-subif ) # description ***connected to vlan 40***
Router ( config-subif ) #ip add 192.168.40.1  255.255.255.0

***
فقط یه نکته ای رو باید بهش توجه کرد ، لینک از طرف پورت fa0/3 سوییچ باید ترانک شده باشد .

switch0(config)#int fa 0/3
switch0(config-if)#switchport mode trunk

بعد از کانفیگ های بالا میتونیم pc هایی که در vlan های دیگه هستند رو ping کنیم.

9


***
از این بحث یه مفهوم SVI ، می مونه که بذارید اون رو تو بحث TELNET & SSH با هم مرور کنیم.

نویسنده : صادق شعبانی
منبع : جزیره سیسکو وب سایت توسینسو
هرگونه نشر و کپی برداری بدون ذکر منبع و نام نویسنده دارای اشکال اخلاقی است
برچسب ها
ردیف عنوان
1 سیسکو آسان است! ( قسمت ابتدایی - فهرست )
2 سیسکو آسان است! ( قسمت اول )
3 سیسکو آسان است! ( قسمت دوم )
4 سیسکو آسان است! ( قسمت سوم)
5 سیسکو آسان است! ( قسمت چهارم )
6 سیسکو آسان است! ( قسمت پنجم : بخش اول )
7 سیسکو آسان است! ( قسمت پنجم : بخش دوم )
8 سیسکو آسان است! ( قسمت پنجم : بخش سوم )
9 سیسکو آسان است! ( قسمت پنجم : بخش چهارم )
10 سیسکو آسان است! ( قسمت پنجم : بخش پنجم )
11 سیسکو آسان است! ( قسمت پنجم : بخش ششم )
دوره مجموعه کل دوره
مطالب مرتبط

در حال دریافت اطلاعات

نظرات
  • سلام دوست عزیز مرسی
    اما فک میکنم یک نکته رو نگفتی یا اینکه من ندیدم...اینکه تو بقیه سویچ ها باید بقیه vlan ها رو تعریف کنیم
  • مرسی بابت نکته سنجی

    +درسته ، من تو این تایپیک در خصوص vlan حرف نزدم . در واقع چون این تایپیک در ادامه قسمت قبل هست و چون در قسمت قبل vlan بندی رو انجام داده بودیم ، در اینجا سناریو رو در خصوص inter vlan routing ادامه دادم.


  • تشکر خیلی مفید بود موفق باشید
  • خواهش میکنم ": )

    در واقع دارم با یاد دادن خودم یاد میگیرم
  • تشکر
    خیلی عالی بیان کردید
  • ممنون
    بسیار عالی
  • اقا چرا من هر کاری میکنم از 40.2 یا 30.2 نمیتونم جایی رو پینگ کنم... حتی دیفالت گت ویشم پینگ نمیکنه....
  • اتصال بین سوئیچ و روترت باید ترانک باشه . اگه از همه موارد مطمئن هستی فایل سناریوت رو برام بزار ببینم اشکال از کجاست.

    موفق باشید ": )
  • مجتبی جان ، سناریو رو مجدد حل کردم ، کانفیگ ها به همراه سناریو حل شده رو براتون میذارم.

    موفق باشید ": )


    دانلود سناریو حل شده
    پکت تریسر 6.2

    
    switch
    ===========
    
    en
    conf t
    
    
    int fa 0/1
    switchport access vlan 10
    
    int fa 0/2
    switchport access vlan 20
    
    int fa 0/3
    switchport access vlan 30
    
    int fa 0/4
    switchport access vlan 40
    
    end
    
    conf t
    int fa 0/5
    switchport mode trunk
    
    
    router
    =============
    int fa 0/0
    no shut 
    
    int fa 0/0.10
    encapsulation dot1q 10
    ip add 192.168.10.1 255.255.255.0
    
    
    int fa 0/0.20
    encapsulation dot1q 20
    ip add 192.168.20.1 255.255.255.0
    
    
    int fa 0/0.30
    encapsulation dot1q 30
    ip add 192.168.30.1 255.255.255.0
    
    
    int fa 0/0.40
    encapsulation dot1q 40
    ip add 192.168.40.1 255.255.255.0
    
    do wr
    end
    
    
    ===============
    show run switch after config
    
    
    Switch#show run
    Building configuration...
    
    Current configuration : 1108 bytes
    !
    version 12.1
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Switch
    !
    !
    !
    spanning-tree mode pvst
    !
    interface FastEthernet0/1
     switchport access vlan 10
    !
    interface FastEthernet0/2
     switchport access vlan 20
    !
    interface FastEthernet0/3
     switchport access vlan 30
    !
    interface FastEthernet0/4
     switchport access vlan 40
    !
    interface FastEthernet0/5
     switchport mode trunk
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface FastEthernet0/13
    !
    interface FastEthernet0/14
    !
    interface FastEthernet0/15
    !
    interface FastEthernet0/16
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    !
    interface FastEthernet0/22
    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    !
    interface Vlan1
     no ip address
     shutdown
    !
    !
    !
    !
    line con 0
    !
    line vty 0 4
     login
    line vty 5 15
     login
    !
    !
    end
    
    ===============
    show run router after config
    
    
    Router#show run
    Building configuration...
    
    Current configuration : 917 bytes
    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Router
    !
    !
    !
    !
    !
    !
    !
    !
    ip cef
    no ipv6 cef
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet0/0.10
     encapsulation dot1Q 10
     ip address 192.168.10.1 255.255.255.0
    !
    interface FastEthernet0/0.20
     encapsulation dot1Q 20
     ip address 192.168.20.1 255.255.255.0
    !
    interface FastEthernet0/0.30
     encapsulation dot1Q 30
     ip address 192.168.30.1 255.255.255.0
    !
    interface FastEthernet0/0.40
     encapsulation dot1Q 40
     ip address 192.168.40.1 255.255.255.0
    !
    interface FastEthernet0/1
     no ip address
     duplex auto
     speed auto
     shutdown
    !
    interface Vlan1
     no ip address
     shutdown
    !
    ip classless
    !
    ip flow-export version 9
    !
    !
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
     login
    !
    !
    !
    end
    
    


  • لینک سناریو ارسالی

    علت عدم پینگ بین چهار vlan :
    ما 2 سوئیچ داریم که در سوئیچ اول vlan 10 , vlan 20 و در سوئیچ دوم vlan 30 , vlan 40

    با دستورات زیر در سوئیچ اول و دوم

    Switch 1#show vlan brief 
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24
    10   VLAN0010                         active    Fa0/1
    20   VLAN0020                         active    Fa0/2
    1002 fddi-default                     active    
    1003 token-ring-default               active    
    1004 fddinet-default                  active    
    1005 trnet-default                    active    
    
    
    ===========================
    
    Switch#show vlan brief 
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/4, Fa0/5, Fa0/6, Fa0/7
                                                    Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                    Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                    Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                    Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                    Fa0/24
    30   VLAN0030                         active    Fa0/2
    40   managment                        active    Fa0/3
    1002 fddi-default                     active    
    1003 token-ring-default               active    
    1004 fddinet-default                  active    
    1005 trnet-default                    active    
    Switch#
    
    

    میبینم که سوئیچ 1 فاقد vlan 30 , vlan 40 و سوئیچ دوم فاقد vlan 10 , vlan 20 هستند که باید برای اشکال آنها ساخته شوند.

    Switch 1 (config)#vlan 30
    Switch 1 (config)#vlan 40
    
    
    Switch 2 (config)#vlan 10
    Switch 2 (config)#vlan 20
    
  • خیلی خیلی ممنون...
  • درود بر شما
  • من همه پورت ها رو از نوع Trunk تعریف کردم

    Multi layer سوییچ من به عنوان سرور انتخاب شده و بقیه سوییچ ها Client اون هستند

    و Vlan هایی که اون تعریف کرده میبنند و مشکلی نیست

    اما مشکل از اونجایی هست که کامپیوتری مثلا دارای Vlan 20 هست اونیکه Vlan 40 براش اکسس شده رو نمیتونه ببینه

    و در سوییچ چند لایه که سرور هم هست دستور IP Routing خورده ولی باز هم همین مشکل وجود دارد و بسته مسیر یابی نمیشه و توی پینگ به مشکل میخورم

    به Vlan ها در همون سوییچ سرور IP هم داده شده

    چند بار این سناریو رو اجرا کردم ولی به همین مشکل بر خوردم

    دیگه گیجه گیج شدم

    تلگرامم : 09213951615

    ممنونم جواب بدید

  • البته بگم من میخوام که مسیر یابی با سوییچ چند لایه که معرفی شده انجام بشه نه از طریق این که روتر بزارم و ROAS اجرا کنک و ساب اینترفیس تعریف کنم و .....

برای ارسال نظر ابتدا به سایت وارد شوید